aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-07-02 18:18:09 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-31 01:03:24 +0200
commit0ca7435fe0ba8ba5c45f85b44987aa20c73497ac (patch)
tree50e5fcc14a2b513325d3cc55d8a38653bb3f0eb6
parent82cfefc2a04aa43e8444a671ba2cdde171cda032 (diff)
downloadguix-0ca7435fe0ba8ba5c45f85b44987aa20c73497ac.tar
guix-0ca7435fe0ba8ba5c45f85b44987aa20c73497ac.tar.gz
gnu: guile-dbd-sqlite3: Replace 'url-fetch' by 'git-fetch'.
Fixes https://debbugs.gnu.org/25913. * gnu/packages/guile-xyz.scm (guile-dbi)[source]: Replace 'url-fetch' by'git-fetch'. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/guile-xyz.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 8f83584724..e91bf88247 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1512,13 +1512,14 @@ It currently supports MySQL, Postgres and SQLite3.")
(name "guile-dbd-sqlite3")
(version "2.1.6")
(source (origin
- (method url-fetch)
- (uri (string-append
- "http://download.gna.org/guile-dbi/guile-dbd-sqlite3-"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://example.org") ;only hosted on Software Heritage
+ (commit "0758c615e9e85ad76d153d5dc6179881f1f50089")))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0rg71jchxd2y8x496s8zmfmikr5g8zxi8zv2ar3f7a23pph92iw2"))))
+ "1rwf3z6ib6nkhfnk2nw8p6fqirdx2pparcrlmsm0i2ii62plpqhb"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -1527,6 +1528,8 @@ It currently supports MySQL, Postgres and SQLite3.")
`(("sqlite" ,sqlite)
("zlib" ,(@ (gnu packages compression) zlib))))
(synopsis "Guile DBI driver for SQLite")
+ ;; Unofficial home-page.
+ ;; Added by b9cbfa52f71505de8447fefabd97f16d0a9cbde6 (2016-06)
(home-page "https://github.com/jkalbhenn/guile-dbd-sqlite3")
(description
"guile-dbi is a library for Guile that provides a convenient interface to