aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSisiutl <sisiutl@egregore.fun>2024-09-20 23:15:36 +0200
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-09-29 23:50:21 +0800
commit093f2fb8722fafcc7c1555cd845289096849f4a2 (patch)
tree125e398a6c5b028905433fbb47718b5445312d1c
parentf19910c7784f5e70c861d8435a5853cd4066bc69 (diff)
downloadguix-093f2fb8722fafcc7c1555cd845289096849f4a2.tar
guix-093f2fb8722fafcc7c1555cd845289096849f4a2.tar.gz
gnu: waypipe: Update to 0.9.1.
* gnu/packages/freedesktop.scm (waypipe): Update to 0.9.1. [inputs]: Add lz4, libva, mesa, libdrm and ffmpeg. [arguments]<#:configure-flags>: Enable lz4, vaapi, dmabuf and video compression. Change-Id: I02891d0fbb0f697083d4599cf960005bbe0b8996 Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
-rw-r--r--gnu/packages/freedesktop.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 23ed788689..6760cddb3e 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -3301,7 +3301,7 @@ notifies the user using any notification daemon implementing
(define-public waypipe
(package
(name "waypipe")
- (version "0.9.0")
+ (version "0.9.1")
(source
(origin
(method git-fetch)
@@ -3310,12 +3310,17 @@ notifies the user using any notification daemon implementing
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0pf1q8kyqyqa7gxar99i35q9np0k4vsf7xlrg12gyzc5k36lhknf"))))
+ (base32 "0pj7l3ix0pp0sfqxfa2hxql0f30vz6hh01fq5kzhs831b632i3z0"))))
(build-system meson-build-system)
(native-inputs
(list pkg-config scdoc
;; For tests
python))
+ (inputs (list lz4 libva mesa libdrm ffmpeg))
+ (arguments
+ (list #:configure-flags
+ #~(list "-Dwith_lz4=enabled" "-Dwith_vaapi=enabled"
+ "-Dwith_dmabuf=enabled" "-Dwith_video=enabled")))
(home-page "https://gitlab.freedesktop.org/mstoeckl/waypipe")
(synopsis "Proxy for Wayland protocol applications")
(description