aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-28 15:31:51 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:26 +0200
commit0823bab5f439d4979a8a2284be3ac2e00244c8d1 (patch)
tree4b95d00c01147ea95293d3daa4e2336da45d3030
parent7c6fb4667dca2cb39003efca48e3de655a38ab35 (diff)
downloadguix-0823bab5f439d4979a8a2284be3ac2e00244c8d1.tar
guix-0823bab5f439d4979a8a2284be3ac2e00244c8d1.tar.gz
gnu: Add texlive-detex-bin.
* gnu/packages/tex.scm (texlive-detex-bin): New variable. (texlive-detex)[propagated-inputs]: Add TEXLIVE-DETEX-BIN. Change-Id: I42aa0aad1a47287705e30184228df62a18799b41
-rw-r--r--gnu/packages/tex.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ddc2874368..00241e8e9f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -34436,6 +34436,7 @@ within the document, or in the document's private package file.")
"08d017wn7a67pmp9b5yhnfg1x2q6f48qaa5ma4bplz9a782icwjy")))
(outputs '("out" "doc"))
(build-system texlive-build-system)
+ (propagated-inputs (list texlive-detex-bin))
(home-page "https://ctan.org/pkg/detex")
(synopsis "Strip TeX from a source file")
(description
@@ -34447,6 +34448,53 @@ commands. The author now considers this program to be obsolete and Piotr
Kubowicz's OpenDetex as its successor.")
(license license:bsd-3)))
+(define-public texlive-detex-bin
+ (package
+ (inherit texlive-bin)
+ (name "texlive-detex-bin")
+ (source
+ (origin
+ (inherit texlive-source)
+ (modules '((guix build utils)
+ (ice-9 ftw)))
+ (snippet
+ #~(let ((delete-other-directories
+ (lambda (root keep)
+ (with-directory-excursion root
+ (for-each
+ delete-file-recursively
+ (scandir
+ "."
+ (lambda (file)
+ (and (not (member file (append keep '("." ".."))))
+ (eq? 'directory (stat:type (stat file)))))))))))
+ (delete-other-directories "libs" '())
+ (delete-other-directories "utils" '())
+ (delete-other-directories "texk" '("detex"))))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments texlive-bin)
+ ((#:configure-flags flags)
+ #~(cons "--enable-detex" (delete "--enable-web2c" #$flags)))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "texk/detex"
+ (invoke "make" "check")))))
+ (replace 'install
+ (lambda _
+ (with-directory-excursion "texk/detex"
+ (invoke "make" "install"))))))))
+ (native-inputs (list pkg-config))
+ (inputs (list texlive-libkpathsea))
+ (propagated-inputs '())
+ (home-page (package-home-page texlive-detex))
+ (synopsis "Binary for @code{texlive-detex}")
+ (description
+ "This package provides the binary for @code{texlive-detex}.")
+ (license (package-license texlive-detex))))
+
(define-public texlive-digestif
(package
(name "texlive-digestif")