aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2024-03-23 10:11:02 -0400
committerMark H Weaver <mhw@netris.org>2024-03-23 16:18:43 -0400
commit060708ef6ca1f4d0c7682a5e570a4546137f8ad0 (patch)
treed923ff8c092d1cafd41de7c7aa20855481b3b81c
parentbf530017f0e847ae895919b32ef37d79fa636a1e (diff)
downloadguix-060708ef6ca1f4d0c7682a5e570a4546137f8ad0.tar
guix-060708ef6ca1f4d0c7682a5e570a4546137f8ad0.tar.gz
gnu: icecat: Update to 115.9.1-guix0-preview1 [fixes CVE-2024-29944].
* gnu/packages/gnuzilla.scm (%icecat-base-version, %icecat-build-id): Update. (icecat-source): Update gnuzilla commit, base version, and hashes.
-rw-r--r--gnu/packages/gnuzilla.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 5df9f1f47b..511a509110 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -522,9 +522,9 @@ variable defined below. It requires guile-json to be installed."
;; XXXX: Workaround 'snippet' limitations.
(define computed-origin-method (@@ (guix packages) computed-origin-method))
-(define %icecat-base-version "115.9.0")
+(define %icecat-base-version "115.9.1")
(define %icecat-version (string-append %icecat-base-version "-guix0-preview1"))
-(define %icecat-build-id "20240319000000") ;must be of the form YYYYMMDDhhmmss
+(define %icecat-build-id "20240323000000") ;must be of the form YYYYMMDDhhmmss
;; 'icecat-source' is a "computed" origin that generates an IceCat tarball
;; from the corresponding upstream Firefox ESR tarball, using the 'makeicecat'
@@ -544,12 +544,12 @@ variable defined below. It requires guile-json to be installed."
"firefox-" upstream-firefox-version ".source.tar.xz"))
(sha256
(base32
- "00r847l2j2wk20wf1plbnz2ifyqkvwqmaqwq6zknsqz6qmqk6fyv"))))
+ "0agr8s42lpbq5gixsgj5kpcvimbnyx6msr4il4rvmf7gpw47hr93"))))
;; The upstream-icecat-base-version may be older than the
;; %icecat-base-version.
- (upstream-icecat-base-version "115.9.0")
- (gnuzilla-commit "d1dab742d12e2ffacae70733b14016287fc46613")
+ (upstream-icecat-base-version "115.9.1")
+ (gnuzilla-commit "a59b8a2c2e4c8b8de47b3ae4d10032154a47a01e")
(gnuzilla-source
(origin
(method git-fetch)
@@ -561,7 +561,7 @@ variable defined below. It requires guile-json to be installed."
(string-take gnuzilla-commit 8)))
(sha256
(base32
- "16z2l0fbbxpl2q80w9mx0x89cq82plkb45jpf172xah0k782akhd"))))
+ "0l07x59c0bmj72n0pdhb4mlphw9nmd88i9jg39xvxcw0cv7bw6qm"))))
;; 'search-patch' returns either a valid file name or #f, so wrap it
;; in 'assume-valid-file-name' to avoid 'local-file' warnings.