aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-15 08:01:27 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-15 12:17:54 +0100
commit0595f60fa749f44eea392059820dd0da33f2c1de (patch)
tree3df6d55340f93803559d366c0bd29f82ad2fc82a
parentbf56c9cb8b4b1885f2ed6ca24022cdf363f9f7ef (diff)
downloadguix-0595f60fa749f44eea392059820dd0da33f2c1de.tar
guix-0595f60fa749f44eea392059820dd0da33f2c1de.tar.gz
gnu: go-github-com-jhillyerd-enmime: Update to 1.2.0.
* gnu/packages/golang.scm (go-github-com-jhillyerd-enmime): Update to 1.2.0. [propagated-inputs]: Remove go-golang-org-x-net, go-github-com-stretchr-testify, go-github-com-ssor-bom, go-github-com-rivo-uniseg, go-github-com-olekukonko-tablewriter, and go-github-com-mattn-go-runewidth. [native-inputs]: Add go-github-com-stretchr-testify. Change-Id: I9e5d16f0547732263e9fcf8a75b95a97c9d4a2df
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 11 insertions, 14 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 97d27d0296..ffe2e35975 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9026,7 +9026,7 @@ text-only mail clients to display them.")
(define-public go-github-com-jhillyerd-enmime
(package
(name "go-github-com-jhillyerd-enmime")
- (version "0.9.4")
+ (version "1.2.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -9035,22 +9035,19 @@ text-only mail clients to display them.")
(file-name (git-file-name name version))
(sha256
(base32
- "124dqm598phbmalyx2gmxk201z9kq4ckvvdq8rc0akjlp24nxqbb"))))
+ "03pir9wq9ha2i2ifj819yv5i0lvrgdn904ksbzgc3k8bqc497ydn"))))
(build-system go-build-system)
(arguments
(list #:import-path "github.com/jhillyerd/enmime"))
- (propagated-inputs (list go-golang-org-x-text
- go-golang-org-x-net
- go-github-com-stretchr-testify
- go-github-com-ssor-bom
- go-github-com-rivo-uniseg
- go-github-com-pkg-errors
- go-github-com-olekukonko-tablewriter
- go-github-com-mattn-go-runewidth
- go-github-com-gogs-chardet
- go-github-com-jaytaylor-html2text
- go-github-com-go-test-deep
- go-github-com-cention-sany-utf7))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs (list
+ go-github-com-cention-sany-utf7
+ go-github-com-go-test-deep
+ go-github-com-gogs-chardet
+ go-github-com-jaytaylor-html2text
+ go-github-com-pkg-errors
+ go-golang-org-x-text))
(home-page "https://github.com/jhillyerd/enmime")
(synopsis "MIME encoder and decoder for Go")
(description