aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-21 21:45:26 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-10-07 10:11:12 -0400
commit0503b104d6b99055b7a149fb0aa91179c69f2935 (patch)
tree3ec038b621512de098e7e302064eff1ec67e5fb2
parent133901a396cf81aa1dcb35586e77a5a78475c4c7 (diff)
downloadguix-0503b104d6b99055b7a149fb0aa91179c69f2935.tar
guix-0503b104d6b99055b7a149fb0aa91179c69f2935.tar.gz
gnu: dconf: Set sysconfdir to /etc.
* gnu/packages/gnome.scm (dconf) [arguments]: Use gexps. [configure-flags]: Add --sysconfdir=/etc. [native-inputs]: Remove labels.
-rw-r--r--gnu/packages/gnome.scm54
1 files changed, 30 insertions, 24 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 840cdabeb9..23ede13958 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4742,33 +4742,39 @@ and RDP protocols.")
(base32
"0cs5nayg080y8pb9b7qccm1ni8wkicdmqp1jsgc22110r6j24zyg"))))
(build-system meson-build-system)
+ (arguments
+ (list
+ #:glib-or-gtk? #t
+ ;; Configure sysconfdir to /etc so that gconf profiles can be written
+ ;; there and loaded without having to set GCONF_PROFILE, which cannot be
+ ;; safely set globally (as a gconf profile is a per-user thing).
+ #:configure-flags #~(list "--sysconfdir=/etc"
+ "-Dgtk_doc=true")
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'increase-test-timeout
+ (lambda _
+ ;; On big-memory systems, the engine test may take
+ ;; much longer than the default of 30 seconds.
+ (substitute* "tests/meson.build"
+ (("test\\(unit_test\\[0\\], exe" all)
+ (string-append all ", timeout: 300"))))))))
+ (native-inputs
+ (list bash-completion
+ libxslt ;for xsltproc
+ libxml2 ;for XML_CATALOG_FILES
+ docbook-xml-4.2
+ docbook-xsl
+ `(,glib "bin")
+ gtk-doc/stable
+ pkg-config
+ python
+ vala))
+ (inputs
+ (list gtk+
+ dbus))
(propagated-inputs
;; In Requires of dconf.pc.
(list glib))
- (inputs
- (list gtk+ dbus))
- (native-inputs
- `(("bash-completion" ,bash-completion)
- ("libxslt" ,libxslt) ;for xsltproc
- ("libxml2" ,libxml2) ;for XML_CATALOG_FILES
- ("docbook-xml" ,docbook-xml-4.2)
- ("docbook-xsl" ,docbook-xsl)
- ("glib:bin" ,glib "bin")
- ("gtk-doc" ,gtk-doc/stable)
- ("pkg-config" ,pkg-config)
- ("python" ,python)
- ("vala" ,vala)))
- (arguments
- `(#:glib-or-gtk? #t
- #:configure-flags '("-Dgtk_doc=true")
- #:phases (modify-phases %standard-phases
- (add-after 'unpack 'increase-test-timeout
- (lambda _
- ;; On big-memory systems, the engine test may take
- ;; much longer than the default of 30 seconds.
- (substitute* "tests/meson.build"
- (("test\\(unit_test\\[0\\], exe" all)
- (string-append all ", timeout: 300"))))))))
(home-page "https://developer.gnome.org/dconf/")
(synopsis "Low-level GNOME configuration system")
(description "Dconf is a low-level configuration system. Its main purpose