aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgemmaro <gemmaro.dev@gmail.com>2024-08-30 00:14:08 +0900
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-23 21:42:17 +0100
commit013b046fca48202f19208a9fe0ae608f02b60953 (patch)
tree16e8ff475aa6d374204a21b4f71ab504bbe8d880
parent23cfb71db3a44c34fbb491152524fa4bd2d8fbba (diff)
downloadguix-013b046fca48202f19208a9fe0ae608f02b60953.tar
guix-013b046fca48202f19208a9fe0ae608f02b60953.tar.gz
gnu: Add go-jfmt.
* gnu/packages/golang-xyz.scm (go-jfmt): New variable. Change-Id: I73a979407e2497a8b8a4a50d1efae04a269c2822 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/golang-xyz.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index ba6adaeaf4..942c5f5138 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -7564,6 +7564,16 @@ tool."))
Trace/Debug/Info/Warn/Error methods on @code{hclog.Logger} are used
correctly.")))
+(define-public go-jfmt
+ (package/inherit go-zgo-at-jfmt
+ (name "go-jfmt")
+ (arguments (list #:install-source? #f
+ #:import-path "zgo.at/jfmt/cmd/jfmt"
+ #:unpack-path "zgo.at/jfmt"))
+ (description
+ (string-append (package-description go-zgo-at-jfmt)
+ " This package provides a command line interface (CLI) tool."))))
+
(define-public go-msgio
(package
(inherit go-github-com-libp2p-go-msgio)