aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-18 14:35:47 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:37 +0200
commit0110ef1c4efac93a1b8e2cffefdb39576f2907b2 (patch)
treec60023a705d56472e6b61cbb4e889aa0696a2f1b
parent5c5fd9e825290e38f759d1a466737482654b8ee6 (diff)
downloadguix-0110ef1c4efac93a1b8e2cffefdb39576f2907b2.tar
guix-0110ef1c4efac93a1b8e2cffefdb39576f2907b2.tar.gz
gnu: texlive-totcount: Remove SIMPLE-TEXLIVE-PACKAGE call.
* gnu/packages/tex.scm (texlive-totcount!): Remove SIMPLE-TEXLIVE-PACKAGE call.
-rw-r--r--gnu/packages/tex.scm41
1 files changed, 18 insertions, 23 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ba99051a1b..1453a3bd07 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13835,31 +13835,26 @@ of occurrences of a substring.")
(license license:lppl1.0+)))
(define-public texlive-totcount
- (let ((template (simple-texlive-package
- "texlive-totcount"
- (list "doc/latex/totcount/"
- "source/latex/totcount/"
- "tex/latex/totcount/")
- (base32
- "1rj9ncip5h2cbdljjqwxqsg14pb4mimzhz290q872n32w7rxkp28"))))
- (package
- (inherit template)
- (outputs '("out" "doc"))
- (build-system texlive-build-system)
- (arguments
- (substitute-keyword-arguments (package-arguments template)
- ((#:tex-directory _ #t) "latex/totcount")
- ((#:tex-format _ #t) "latex")
- ((#:build-targets _ '()) '(list "totcount.ins"))))
- (propagated-inputs
- (list texlive-graphics))
- (home-page "https://ctan.org/pkg/totcount")
- (synopsis "Find the last value of a counter")
- (description
- "This package records the value that was last set, for any counter of
+ (package
+ (name "texlive-totcount")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/totcount/" "source/latex/totcount/"
+ "tex/latex/totcount/")
+ (base32
+ "1rj9ncip5h2cbdljjqwxqsg14pb4mimzhz290q872n32w7rxkp28")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:tex-format "latex"))
+ (propagated-inputs (list texlive-graphics))
+ (home-page "https://ctan.org/pkg/totcount")
+ (synopsis "Find the last value of a counter")
+ (description
+ "This package records the value that was last set, for any counter of
interest. Since most such counters are simply incremented when they are
changed, the recorded value will usually be the maximum value.")
- (license license:lppl1.3c+))))
+ (license license:lppl1.3c+)))
(define-deprecated-package texlive-latex-totcount texlive-totcount)