aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-10-20 15:39:11 +0100
committerChristopher Baines <mail@cbaines.net>2019-10-20 15:39:11 +0100
commit4746a939cb9bc722de88b61a5bc77fc8b04e99c5 (patch)
tree45f5dc0c51ebe97e16f9681c5c52bdabcd96e3fc
parent0fe041bd9fa87d23b44969a3bcd99b1165a0f06e (diff)
downloadguix-yasm-disable-parallel-tests.tar
guix-yasm-disable-parallel-tests.tar.gz
gnu: yasm: Disable parallel tests.yasm-disable-parallel-tests
* gnu/packages/assembly.scm (yasm)[arguments]: Set #:parallel-tests? to #f.
-rw-r--r--gnu/packages/assembly.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index 26a6d23a8a..50f798ba83 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -99,6 +99,10 @@ has strong support for macros.")
(base32
"0gv0slmm0qpq91za3v2v9glff3il594x5xsrbgab7xcmnh0ndkix"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:parallel-tests? #f)) ; Some tests fail
+ ; non-deterministically when run in
+ ; parallel
(inputs
`(("python" ,python-wrapper)
("xmlto" ,xmlto)))