aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-08-01 07:42:59 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-28 18:11:12 +0000
commita5c0d6e73feab1936e7b865fb568e3319d741707 (patch)
treeadaeef9d1b4303657715537bbe1ff2141a290426
parent82ab22115748d4970058401b43ed1111baf14070 (diff)
downloadguix-wip-rails-extra-packages-fixes.tar
guix-wip-rails-extra-packages-fixes.tar.gz
gnu: Add ruby-jeweler.wip-rails-extra-packages-fixes
* gnu/packages/ruby.scm (ruby-jeweler): New variable.
-rw-r--r--gnu/packages/ruby.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index c71405ea43..b1a81832dd 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4382,6 +4382,47 @@ when working with Ruby code.")
;; There is no mention of the "or later" clause.
(license license:gpl2)))
+(define-public ruby-jeweler
+ (package
+ (name "ruby-jeweler")
+ (version "2.3.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "jeweler" version))
+ (sha256
+ (base32
+ "0jbivh9vf9wm91kwjnlcvswqyk2g24bnxj9gavinx9jh4bphagi5"))))
+ (build-system ruby-build-system)
+ (propagated-inputs
+ `(("ruby-builder" ,ruby-builder)
+ ("bundler" ,bundler)
+ ("ruby-git" ,ruby-git)
+ ("ruby-github-api" ,ruby-github-api)
+ ("ruby-highline" ,ruby-highline)
+ ("ruby-nokogiri" ,ruby-nokogiri)
+ ("ruby-psych" ,ruby-psych)
+ ("ruby-rake" ,ruby-rake)
+ ("ruby-rdoc" ,ruby-rdoc)
+ ("ruby-semver2" ,ruby-semver2)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'delete-Gemfile.lock
+ (lambda _
+ ;; Bundler isn't being used for fetching dependendencies, so
+ ;; delete the Gemfile.lock
+ (delete-file "Gemfile.lock")
+ #t
+ )))))
+ (synopsis
+ "Simple and opinionated helper for creating Rubygem projects on GitHub")
+ (description
+ "Simple and opinionated helper for creating Rubygem projects on GitHub")
+ (home-page
+ "http://github.com/technicalpickles/jeweler")
+ (license license:expat)))
+
(define-public ruby-json
(package
(name "ruby-json")