aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2020-06-03 18:31:00 -0500
committerChristopher Baines <mail@cbaines.net>2020-06-25 17:47:32 +0100
commitcbef56540c328064ffd87b5c1e7af9cc3d520b25 (patch)
tree7338bf26de785b29a82a6ee3f91a76df20a26dd1
parentd613991a8ebe5d4b3a7706f8f0dd52f16fc1c50a (diff)
downloadguix-update-go-to-1.14.4.tar
guix-update-go-to-1.14.4.tar.gz
gnu: go: Update to 1.14.4.update-go-to-1.14.4
* gnu/packages/golang.scm (go): Update to 1.14.4. * gnu/packages/docker.scm (docker, docker-cli): Update to 19.03.11.
-rw-r--r--gnu/packages/docker.scm13
-rw-r--r--gnu/packages/golang.scm27
2 files changed, 30 insertions, 10 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index cdde807046..3dd706cbe9 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -390,6 +391,17 @@ built-in registry server of Docker.")
(substitute* "pkg/archive/archive.go"
(("string\\{\"xz")
(string-append "string{\"" (assoc-ref inputs "xz") "/bin/xz")))
+ ;; TODO: Remove when Docker proper uses v1.14.x to build
+ (substitute* "registry/resumable/resumablerequestreader_test.go"
+ (("I%27m%20not%20an%20url" all)
+ (string-append "\"" all "\"")))
+ ;; TODO: Remove when Docker proper uses v1.14.x to build
+ (substitute* "vendor/gotest.tools/x/subtest/context.go"
+ (("func \\(tc \\*testcase\\) Cleanup\\(" all)
+ (string-append all "func()"))
+ (("tc\\.Cleanup\\(" all)
+ (string-append all "nil")))
+
(let ((source-files (filter (lambda (name)
(not (string-contains name "test")))
(find-files "." "\\.go$"))))
@@ -488,6 +500,7 @@ built-in registry server of Docker.")
;; Timeouts after 5 min.
(delete-file "plugin/manager_linux_test.go")
;; Operation not permitted.
+ (delete-file "daemon/graphdriver/aufs/aufs_test.go")
(delete-file "daemon/graphdriver/btrfs/btrfs_test.go")
(delete-file "daemon/graphdriver/overlay/overlay_test.go")
(delete-file "daemon/graphdriver/overlay2/overlay_test.go")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c5ca0d0352..8163950a26 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2018 Tomáš Čech <sleep_walker@gnu.org>
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
-;;; Copyright @ 2018, 2019 Katherine Cox-Buday <cox.katherine.e@gmail.com>
+;;; Copyright @ 2018, 2019, 2020 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright @ 2019 Giovanni Biscuolo <g@xelera.eu>
;;; Copyright @ 2019, 2020 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019, 2020 Arun Isaac <arunisaac@systemreboot.net>
@@ -218,19 +218,21 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(supported-systems '("x86_64-linux" "i686-linux" "armhf-linux" "aarch64-linux"))
(license license:bsd-3)))
-(define-public go-1.13
+(define-public go-1.14
(package
(inherit go-1.4)
(name "go")
- (version "1.13.9")
+ (version "1.14.4")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://storage.googleapis.com/golang/"
- name version ".src.tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/golang/go.git")
+ (commit (string-append "go" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "07gksk9194wa90xyd6yhagxfv7syvsx29bh8ypc4mg700vc1kfrl"))))
+ "08bazglmqp123c9dgrxflvxd011xsqfxsgah2kzbvca0mhm6qcm3"))))
(arguments
(substitute-keyword-arguments (package-arguments go-1.4)
((#:system system)
@@ -266,7 +268,13 @@ in the style of communicating sequential processes (@dfn{CSP}).")
'("cmd/go/testdata/script/mod_case_cgo.txt"
"cmd/go/testdata/script/list_find.txt"
"cmd/go/testdata/script/list_compiled_imports.txt"
- "cmd/go/testdata/script/cgo_syso_issue29253.txt"))
+ "cmd/go/testdata/script/cgo_syso_issue29253.txt"
+ "cmd/go/testdata/script/cover_cgo.txt"
+ "cmd/go/testdata/script/cover_cgo_xtest.txt"
+ "cmd/go/testdata/script/cover_cgo_extra_test.txt"
+ "cmd/go/testdata/script/cover_cgo_extra_file.txt"))
+
+ (for-each make-file-writable (find-files "."))
(substitute* "os/os_test.go"
(("/usr/bin") (getcwd))
@@ -369,7 +377,6 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(setenv "GOROOT_FINAL" output)
(setenv "CGO_ENABLED" "1")
(invoke "sh" "all.bash"))))
-
(replace 'install
;; TODO: Most of this could be factorized with Go 1.4.
(lambda* (#:key outputs #:allow-other-keys)
@@ -415,7 +422,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
,@(package-native-inputs go-1.4)))
(supported-systems %supported-systems)))
-(define-public go go-1.13)
+(define-public go go-1.14)
(define-public go-github-com-alsm-ioprogress
(let ((commit "063c3725f436e7fba0c8f588547bee21ffec7ac5")