aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-11-07 19:41:46 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-05 20:29:17 +0000
commit9c5f4b82bb0ed6a0447a68f9cb18c4da5f692acf (patch)
tree69fc363847de49c9d457b1681db88be556129be3
parent9718265eecf8e463405954886be71c4dbd52358a (diff)
downloadguix-update-capnproto-and-mash.tar
guix-update-capnproto-and-mash.tar.gz
gnu: capnproto: Update to 0.7.0.update-capnproto-and-mash
* gnu/packages/serialization.scm (capnproto): Update to 0.7.0. [arguments]: Add new 'use-tmp-for-tempory-files phase.
-rw-r--r--gnu/packages/serialization.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 2df0ce1364..2d61f7451b 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -306,7 +306,7 @@ it a convenient format to store user input files.")
(define-public capnproto
(package
(name "capnproto")
- (version "0.6.1")
+ (version "0.7.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -314,7 +314,7 @@ it a convenient format to store user input files.")
version ".tar.gz"))
(sha256
(base32
- "010s9yhq4531wvdfrdf2477zswhck6cjfby79w73rff3v06090l0"))))
+ "0hfdnhlbskagzgvby8wy6lrxj53zfzpfqimbhga68c0ji2yw1969"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -324,6 +324,14 @@ it a convenient format to store user input files.")
;; Workaround for test that tries to resolve port name from
;; /etc/services, which is not present in build environment.
(substitute* "src/kj/async-io-test.c++" ((":http") ":80"))
+ #t))
+ (add-before 'check 'use-tmp-for-tempory-files
+ (lambda _
+ ;; Use /tmp for tempory files, as the default /var/tmp directory
+ ;; doesn't exist.
+ (substitute* "src/kj/filesystem-disk-test.c++"
+ (("VAR\\_TMP \"/var/tmp\"")
+ "VAR_TMP \"/tmp\""))
#t)))))
(home-page "https://capnproto.org")
(synopsis "Capability-based RPC and serialization system")