aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-02-06 08:36:12 +0000
committerChristopher Baines <mail@cbaines.net>2020-02-06 08:36:12 +0000
commit4c591f65794b5b2cacb582bea0fc575eb31af14e (patch)
tree87ae9917b82aa67b39d5e2d3dd107a2cede1ac72
parent8534c9491d86406ade201bacc3b14fdf63a1f39d (diff)
downloadguix-run-subversion-tests-in-parallel.tar
guix-run-subversion-tests-in-parallel.tar.gz
gnu: subversion: Support running the tests in parallel.run-subversion-tests-in-parallel
This drops the time to build the package on my machine from ~14 minutes to ~5 minutes. * gnu/packages/version-control.scm (subversion)[arguments]: Add set-PARALLEL phase to set the PARALLEL environment variable.
-rw-r--r--gnu/packages/version-control.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 20db6b4b08..140eccb7ec 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1434,6 +1434,10 @@ following features:
(substitute* "subversion/tests/libsvn_repos/repos-test.c"
(("#!/bin/sh") (string-append "#!" (which "sh"))))
#t))
+ (add-before 'check 'set-PARALLEL
+ (lambda _
+ (setenv "PARALLEL" (number->string (parallel-job-count)))
+ #t))
(add-after 'install 'install-perl-bindings
(lambda* (#:key outputs #:allow-other-keys)
;; Follow the instructions from 'subversion/bindings/swig/INSTALL'.