aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:40:29 +0100
committerChristopher Baines <mail@cbaines.net>2018-09-16 18:29:45 +0100
commit5edef88b8873ad73ceb74c8801487fc16d64965c (patch)
treefd04d1312f5e1d1470e9cd4a3cc57c5218c0560d
parent1b6f5475a1e05797f096aca038f2a14b9feb5707 (diff)
downloadguix-ruby-rails-first-4-patches.tar
guix-ruby-rails-first-4-patches.tar.gz
gnu: Add ruby-multi-test.ruby-rails-first-4-patches
* gnu/packages/ruby.scm (ruby-multi-test): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/ruby.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index b7bf6ca736..76e3cee81e 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2325,6 +2325,32 @@ NSJSONSerialization, gson.rb, JrJackson, and OkJson.")
(home-page "https://github.com/intridea/multi_json")
(license license:expat)))
+(define-public ruby-multi-test
+ (package
+ (name "ruby-multi-test")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "multi_test" version))
+ (sha256
+ (base32
+ "1sx356q81plr67hg16jfwz9hcqvnk03bd9n75pmdw8pfxjfy1yxd"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(;; Tests require different sets of specific gem versions to be available,
+ ;; and there is no gemfile that specifies the newest versions of
+ ;; dependencies to be tested.
+ #:tests? #f))
+ (synopsis
+ "Interface to testing libraries loaded into a running Ruby process")
+ (description
+ "@code{multi_test} provides a uniform interface onto whatever testing
+libraries that have been loaded into a running Ruby process to help control
+rogue test/unit/autorun requires.")
+ (home-page "https://github.com/cucumber/multi_test")
+ (license license:expat)))
+
(define-public ruby-arel
(package
(name "ruby-arel")