aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-07-14 11:57:38 +0100
committerChristopher Baines <mail@cbaines.net>2018-07-15 22:19:39 +0100
commitfe27238cea9fd85e0cd42ea1ad9fdc3a73b9758d (patch)
tree035897115eceba8a6cbff7aa8844a90759d5395d
parent0d354666d35ea54b024f45a6b3d835e8879a5df5 (diff)
downloadguix-ruby-build-system-error-or-return-true.tar
guix-ruby-build-system-error-or-return-true.tar.gz
gnu: ruby-options: Return #t from set-LIB phase.ruby-build-system-error-or-return-true
* gnu/packages/ruby.scm (ruby-options)[arguments]: Return #t from the set-LIB phase.
-rw-r--r--gnu/packages/ruby.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 1602fd5d5e..9a74f16c01 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -883,7 +883,8 @@ complexity.")
(lambda _
;; This is used in the Rakefile, and setting it avoids an issue
;; with running the tests.
- (setenv "LIB" "options"))))))
+ (setenv "LIB" "options")
+ #t)))))
(synopsis "Ruby library to parse options from *args cleanly")
(description
"The @code{options} library helps with parsing keyword options in Ruby