aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-10-07 10:38:26 +0100
committerChristopher Baines <mail@cbaines.net>2018-10-12 08:23:17 +0100
commit50135ff896441f6b9e10fbfc9bfd35bf06ff1c13 (patch)
tree9f3ac6dc1edd01e8d5fd010668a910c8ec5c1e4d
parente9ab649e1e6400cdbf5147144903c1212cba798a (diff)
downloadguix-remove-two-duplicate-ruby-gem-packages.tar
guix-remove-two-duplicate-ruby-gem-packages.tar.gz
gnu: Remove duplicate ruby-yard package definition.remove-two-duplicate-ruby-gem-packages
* gnu/packages/ruby.scm (ruby-yard): Remove one of the two package definitions, and update the other to the latest release.
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 2 insertions, 23 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 2c5777fdf8..7e8c8be290 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3766,7 +3766,7 @@ A modified copy of yajl is used, and included in the package.")
(define-public ruby-yard
(package
(name "ruby-yard")
- (version "0.9.6")
+ (version "0.9.16")
(source
(origin
(method url-fetch)
@@ -3776,7 +3776,7 @@ A modified copy of yajl is used, and included in the package.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0rsz4bghgx7fryzyhlz8wlnd2m9xgyvf1xhrq58mnzfrrfm41bdg"))))
+ "0sqpbayy9sb406jh0zqg6qha1xds863qz9531dh6vp58hc00clfq"))))
(build-system ruby-build-system)
(arguments
`(#:phases
@@ -5673,27 +5673,6 @@ support the tests found in Prawn, a pure Ruby PDF generation library.")
functionality from Prawn.")
(license license:gpl3+)))
-(define-public ruby-yard
- (package
- (name "ruby-yard")
- (version "0.9.16")
- (source (origin
- (method url-fetch)
- (uri (rubygems-uri "yard" version))
- (sha256
- (base32
- "0lmmr1839qgbb3zxfa7jf5mzy17yjl1yirwlgzdhws4452gqhn67"))))
- (build-system ruby-build-system)
- (arguments `(#:test-target "spec"))
- (home-page "https://yardoc.org/")
- (synopsis "Ruby documentation tool")
- (description "YARD is a documentation generation tool for the Ruby
-programming language. It enables the user to generate consistent, usable
-documentation that can be exported to a number of formats very easily, and
-also supports extending for custom Ruby constructs such as custom class level
-definitions.")
- (license license:expat)))
-
(define-public ruby-prawn
(package
(name "ruby-prawn")