aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-12-17 16:16:14 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-24 15:13:27 +0000
commitb200c48e8c988a3fd3ed32b8562cabc7fbf6e45f (patch)
tree9ea48713f1cef5ffab792a7e50c57b09dc32d5f4
parentcd053f26fabb5166e29a4113e1785be20892c25d (diff)
downloadguix-python-machine-learning.tar
guix-python-machine-learning.tar.gz
gnu: Add python-pattern.python-machine-learning
* gnu/packages/python.scm (python-pattern): New variable.
-rw-r--r--gnu/packages/python-web.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 58c5566f42..60d295f169 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -42,6 +42,7 @@
(define-module (gnu packages python-web)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system python)
#:use-module (gnu packages)
#:use-module (gnu packages check)
@@ -1317,6 +1318,37 @@ and to spawn subprocesses to handle requests.")
(define-public python2-wsgiproxy2
(package-with-python2 python-wsgiproxy2))
+(define-public python-pattern
+ (package
+ (name "python-pattern")
+ (version "2.6-development")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/clips/pattern")
+ (commit "ec95f97b2e34c2232e7c43ef1e34e3f0dea6654b")))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "19vs4bfrpx5ij97z3d0x4hj25pmi1bb1sa4z1q8im6g2415nb81p"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f))
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (propagated-inputs
+ `(("python-nltk" ,python-nltk)))
+ (home-page "http://www.clips.ua.ac.be/pattern")
+ (synopsis
+ "Web mining module for Python, with tools for scraping, natural language processing, machine learning, network analysis and visualization.")
+ (description
+ "Web mining module for Python, with tools for scraping, natural language processing, machine learning, network analysis and visualization.")
+ (license #f)))
+
+(define-public python2-pattern
+ (package-with-python2 python-pattern))
+
(define-public python-pastedeploy
(package
(name "python-pastedeploy")