aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-01-03 22:03:34 +0000
committerChristopher Baines <mail@cbaines.net>2019-02-11 09:52:08 +0000
commit8b7e6d005e9f709bece4bba05186a4abda3e4deb (patch)
tree35ec6319bc3c5fec812c5881ad96dfc7dc13de6e
parentd7dccedc0d6352ed0fcd5cbca9fa5d8052533156 (diff)
downloadguix-postgresql-add-openssl-support.tar
guix-postgresql-add-openssl-support.tar.gz
gnu: postgresql: Build with openssl support.postgresql-add-openssl-support
* gnu/packages/databases.scm (postgresql)[arguments]: Add --with-openssl to [inputs]: Add openssl.
-rw-r--r--gnu/packages/databases.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index cc4e6631f8..dd93747ed6 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -698,7 +698,7 @@ as a drop-in replacement of MySQL.")
(patches (search-patches "postgresql-disable-resolve_symlinks.patch"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '("--with-uuid=e2fs")
+ `(#:configure-flags '("--with-uuid=e2fs" "--with-openssl")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-/bin/sh
@@ -717,6 +717,7 @@ as a drop-in replacement of MySQL.")
(inputs
`(("readline" ,readline)
("libuuid" ,util-linux)
+ ("openssl" ,openssl)
("zlib" ,zlib)))
(home-page "https://www.postgresql.org/")
(synopsis "Powerful object-relational database system")