aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2021-06-04 13:54:20 +0100
committerChristopher Baines <mail@cbaines.net>2021-06-04 13:54:20 +0100
commit25ff7f41295b9bcda984499e23654c0d20135320 (patch)
tree91d60f679b1bca9bdbad4eba1f12436f0fbc3aaa
parent1ea00cceefa4a2e3832423bb80180256531ff589 (diff)
downloadguix-nginx-add-some-modules.tar
guix-nginx-add-some-modules.tar.gz
gnu: nginx: Build with support for a few more modules.nginx-add-some-modules
I think this is generally useful. Personally, I want the HTTP gzip static and gunzip ones for serving gzip compressed log files, and I spotted that the HTTP sub and addition ones are easy to enable as well. * gnu/packages/web.scm (nginx)[arguments]: Add the following configure flags: --with-http_gzip_static_module, --with-http_gunzip_module, --with-http_addition_module, --with-http_sub_module.
-rw-r--r--gnu/packages/web.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 4753eca8da..15befe7e6d 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -399,6 +399,10 @@ the same, being completely separated from the Internet.")
"--with-http_ssl_module"
"--with-http_v2_module"
"--with-http_xslt_module"
+ "--with-http_gzip_static_module"
+ "--with-http_gunzip_module"
+ "--with-http_addition_module"
+ "--with-http_sub_module"
"--with-pcre-jit"
"--with-debug"
"--with-stream"