aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2020-09-11 20:08:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-09-11 21:58:58 +0200
commit496a52dc410e287aa2bd03e962fdc110cfb2a1cc (patch)
tree829d12234ce31a7f73dc3c19c43cef7360c56b10
parentc23ff34423bec6982d59cddd295018ae5f4c68b2 (diff)
downloadguix-496a52dc410e287aa2bd03e962fdc110cfb2a1cc.tar
guix-496a52dc410e287aa2bd03e962fdc110cfb2a1cc.tar.gz
gnu: r-qtl: Move to (gnu packages cran).
* gnu/packages/bioinformatics.scm (r-qtl): Move from here... * gnu/packages/cran.scm (r-qtl): ...to here. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/bioinformatics.scm25
-rw-r--r--gnu/packages/cran.scm26
2 files changed, 26 insertions, 25 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index cab3df222c..ae728f09dc 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8510,31 +8510,6 @@ Stephens (1990).")
throughput genetic sequencing data sets using regression methods.")
(license license:artistic2.0)))
-(define-public r-qtl
- (package
- (name "r-qtl")
- (version "1.46-2")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://cran/src/contrib/qtl_"
- version ".tar.gz"))
- (sha256
- (base32
- "0rbwcnvyy96gq1dsgpxx03pv423qya26h6ws5y0blj3blfdmj83a"))))
- (build-system r-build-system)
- (home-page "https://rqtl.org/")
- (synopsis "R package for analyzing QTL experiments in genetics")
- (description "R/qtl is an extension library for the R statistics
-system. It is used to analyze experimental crosses for identifying
-genes contributing to variation in quantitative traits (so-called
-quantitative trait loci, QTLs).
-
-Using a hidden Markov model, R/qtl estimates genetic maps, to
-identify genotyping errors, and to perform single-QTL and two-QTL,
-two-dimensional genome scans.")
- (license license:gpl3)))
-
(define-public r-qtl2
(package
(name "r-qtl2")
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0d10793e9f..980ad17594 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2015, 2016 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2016, 2017 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016, 2017, 2018, 2020 Roel Janssen <roel@gnu.org>
;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -24330,3 +24331,28 @@ are tests where the test statistic is the sum of the product of a
covariate (usually group indicator) and the scores.")
;; Any version of the GPL
(license license:gpl2+)))
+
+(define-public r-qtl
+ (package
+ (name "r-qtl")
+ (version "1.46-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cran/src/contrib/qtl_"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0rbwcnvyy96gq1dsgpxx03pv423qya26h6ws5y0blj3blfdmj83a"))))
+ (build-system r-build-system)
+ (home-page "https://rqtl.org/")
+ (synopsis "R package for analyzing QTL experiments in genetics")
+ (description "R/qtl is an extension library for the R statistics
+system. It is used to analyze experimental crosses for identifying
+genes contributing to variation in quantitative traits (so-called
+quantitative trait loci, QTLs).
+
+Using a hidden Markov model, R/qtl estimates genetic maps, to
+identify genotyping errors, and to perform single-QTL and two-QTL,
+two-dimensional genome scans.")
+ (license license:gpl3)))