aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-09-13 09:31:15 +0100
committerChristopher Baines <mail@cbaines.net>2020-09-13 09:38:03 +0100
commit35c0d7e88423671cc96d3c552eac2b4f6b1fe8d7 (patch)
treef54f531fcf1ed8898d29c44dc6c9281f3482aee6
parent2c0b715389a723ecd35e9cc2694deb585a91ea76 (diff)
downloadguix-josm-improvements.tar
guix-josm-improvements.tar.gz
gnu: josm: Fix formatting and install more files.josm-improvements
This means that JOSM appears in the GNOME Shell menu. * gnu/packages/geo.scm (josm)[source]: Replace tab character. [arguments]: Reduce line length, and add install-share-directories phase.
-rw-r--r--gnu/packages/geo.scm18
1 files changed, 16 insertions, 2 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index ab1d691c6c..a896364c35 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1290,7 +1290,7 @@ to the OSM opening hours specification.")
(modules '((guix build utils)))
(snippet
'(begin
- (for-each delete-file (find-files "." ".*.jar$"))
+ (for-each delete-file (find-files "." ".*.jar$"))
#t))))
(build-system ant-build-system)
(native-inputs
@@ -1339,7 +1339,8 @@ to the OSM opening hours specification.")
(filter
(lambda (s)
(let ((source (assoc-ref inputs "source")))
- (not (equal? (substring s 0 (string-length source)) source))))
+ (not (equal? (substring s 0 (string-length source))
+ source))))
(string-split (getenv "CLASSPATH") #\:))
":"))
#t))
@@ -1386,6 +1387,19 @@ to the OSM opening hours specification.")
"Is-Local-Build: true\n"
"Build-Date: 1970-01-01 00:00:00 +0000\n"))))
#t))
+ (add-after 'install 'install-share-directories
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (share-directories '("applications" "icons" "man" "menu"
+ "metainfo" "mime" "pixmaps")))
+ (for-each (lambda (directory)
+ (copy-recursively (string-append
+ "native/linux/tested/usr/share/"
+ directory)
+ (string-append
+ out "/share/" directory)))
+ share-directories))
+ #t))
(add-after 'install 'install-bin
(lambda* (#:key outputs inputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))