aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2022-10-25 11:48:12 +0100
committerChristopher Baines <mail@cbaines.net>2022-10-25 11:48:12 +0100
commit034385f3053d07527e9e2b5cec34dd4f5bc994b8 (patch)
tree589974651deab851ec78be11bbf8e25ee20f6b58
parenta2f6900761d81ca572a9de92868ed225c2893111 (diff)
downloadguix-gst-plugins-bad-camerabin-test.tar
guix-gst-plugins-bad-camerabin-test.tar.gz
gnu: gst-plugins-bad: Skip elements/camerabin test on some systems.gst-plugins-bad-camerabin-test
It seems to frequently fail on i686-linux and aarch64-linux. * gnu/packages/gstreamer.scm (gst-plugins-bad)[arguments]: Skip the elements/camerabin test on i686-linux and aarch64-linux.
-rw-r--r--gnu/packages/gstreamer.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index a92588a9e2..c211816bf8 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -791,6 +791,14 @@ model to base your own plug-in on, here it is.")
;; FIXME: Why is this failing.
((".*elements/dash_mpd\\.c.*") "")
+ #$@(if (member (%current-system)
+ '("i686-linux" "aarch64-linux"))
+ ;; This test is flaky:
+ ;; https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/1244
+ `((("'elements/camerabin\\.c'\\]\\],")
+ "'elements/camerabin.c'], true, ],"))
+ '())
+
;; These tests are flaky and occasionally time out:
;; https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/issues/932
((".*elements/curlhttpsrc\\.c.*") "")