aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-06-22 15:57:41 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-10-27 16:40:18 +0200
commitaef2425666b47f5b9df24db2e0193e582d0782a5 (patch)
tree91185ae6a5a5a2c3e082231372d6e32b7ddd276e
parent695d7720efbe72f03227a84ce557eb1a4f37d4fa (diff)
downloadguix-aef2425666b47f5b9df24db2e0193e582d0782a5.tar
guix-aef2425666b47f5b9df24db2e0193e582d0782a5.tar.gz
gnu: Add r-aseb.
* gnu/packages/bioconductor.scm (r-aseb): New variable.
-rw-r--r--gnu/packages/bioconductor.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 2ace372c58..b8535250f9 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2317,6 +2317,33 @@ reproducible gene expression signatures capable of accurately distinguishing
tumor samples from healthy controls.")
(license license:artistic2.0)))
+(define-public r-aseb
+ (package
+ (name "r-aseb")
+ (version "1.40.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ASEB" version))
+ (sha256
+ (base32
+ "1i0r4vimk6is4j4rr14ajp8papznpmmr0bhwd96s8w53cqdqph7p"))))
+ (properties `((upstream-name . "ASEB")))
+ (build-system r-build-system)
+ (home-page "https://bioconductor.org/packages/ASEB")
+ (synopsis "Predict acetylated lysine sites")
+ (description
+ "ASEB is an R package to predict lysine sites that can be acetylated by a
+specific @dfn{KAT} (K-acetyl-transferases) family. Lysine acetylation is a
+well-studied posttranslational modification on kinds of proteins. About four
+thousand lysine acetylation sites and over 20 lysine KATs have been
+identified. However, which KAT is responsible for a given protein or lysine
+site acetylation is mostly unknown. In this package, we use a
+@dfn{GSEA}-like (Gene Set Enrichment Analysis) method to make predictions.
+GSEA method was developed and successfully used to detect coordinated
+expression changes and find the putative functions of the long non-coding
+RNAs.")
+ (license license:gpl3+)))
+
(define-public r-asgsca
(package
(name "r-asgsca")