aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2021-12-27 13:04:30 +0000
committerChristopher Baines <mail@cbaines.net>2021-12-27 13:04:30 +0000
commit0f571e7940ea2a2ae07b8a2e67ca3ba86f517802 (patch)
tree41dcd8e4e3333359308eb36f37d9f24e5928a87b
parentaee90c84b2ced501416b591dae349f39e46b5f49 (diff)
downloadguix-emptyepsilon.tar
guix-emptyepsilon.tar.gz
-rw-r--r--gnu/packages/games.scm22
-rw-r--r--gnu/packages/graphics.scm50
2 files changed, 72 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 781074ed7c..20559a4534 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3855,6 +3855,28 @@ Protocol).")
(home-page "https://www.gnu.org/software/gnugo/")
(license license:gpl3+)))
+(define-public emptyepsilon
+ (package
+ (name "emptyepsilon")
+ (version "2021.11.27")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/daid/EmptyEpsilon")
+ (commit (string-append "EE-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "19vbijp9wmpmmmh3zv1ba77hw4s1306p982494sq5k71hrikrarm"))))
+ (build-system cmake-build-system)
+ (inputs
+ (list sfml))
+ (home-page "")
+ (synopsis "")
+ (description
+ "")
+ (license (list license:expat))))
+
(define-public extremetuxracer
(package
(name "extremetuxracer")
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 3be37d7841..1ed589e28c 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1919,6 +1919,56 @@ Some feature highlights:
@end itemize\n")
(license license:gpl3+))))
+(define-public meshoptimizer
+ (package
+ (name "meshoptimizer")
+ (version "0.17")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/coin3d/coin")
+ (commit (string-append "Coin-" version))
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ayg0hl8wanhadahm5xbghghxw1qjwqbrs3dl3ngnff027hsyf8p"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Delete binaries
+ (for-each delete-file
+ '("cfg/csubst.exe"
+ "cfg/wrapmsvc.exe"))
+ ;; Delete references to packaging tool cpack. Otherwise the build
+ ;; fails with "add_subdirectory given source "cpack.d" which is not
+ ;; an existing directory."
+ (substitute* "CMakeLists.txt"
+ ((".*cpack.d.*") ""))
+ #t))))
+ (build-system cmake-build-system)
+ (native-inputs
+ (list doxygen graphviz))
+ (inputs
+ (list boost freeglut glew))
+ (arguments
+ `(#:configure-flags
+ (list
+ "-DCOIN_BUILD_DOCUMENTATION_MAN=ON"
+ (string-append "-DBOOST_ROOT="
+ (assoc-ref %build-inputs "boost")))))
+ (home-page "https://github.com/coin3d/coin")
+ (synopsis
+ "High-level 3D visualization library with Open Inventor 2.1 API")
+ (description
+ "Coin is a 3D graphics library with an Application Programming Interface
+based on the Open Inventor 2.1 API. For those who are not familiar with Open
+Inventor, it is a scene-graph based retain-mode rendering and model interaction
+library, written in C++, which has become the de facto standard graphics
+library for 3D visualization and visual simulation software in the scientific
+and engineering community.")
+ (license license:bsd-3)))
+
(define-public monado
(package
(name "monado")