aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-24 15:58:54 +0000
committerChristopher Baines <mail@cbaines.net>2018-06-11 19:36:05 +0100
commitcef4d008626419a0f345468b9eeefa0ad7cd38b7 (patch)
treee7ef60fcc2bc15de12012e71384d5a01d8c99917
parentb19950a184a9b7506f9be4ecaa043e5a7e460b52 (diff)
downloadguix-emacs-puppet-mode.tar
guix-emacs-puppet-mode.tar.gz
gnu: Add emacs-puppet-mode.emacs-puppet-mode
* gnu/packages/emacs.scm (emacs-puppet-mode): New variable.
-rw-r--r--gnu/packages/emacs.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 9caa01a0fd..039f52a560 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3014,6 +3014,33 @@ This provides a basic API and common UI widgets such as popup tooltips
and popup menus.")
(license license:gpl3+)))
+(define-public emacs-puppet-mode
+ (let ((commit "b3ed5057166a4f49dfa9be638523a348b55a2fd2")
+ (revision "1"))
+ (package
+ (name "emacs-puppet-mode")
+ ;; The last release, 0.3 was several years ago, and there have been many
+ ;; commits since
+ (version (git-version "0.3" revision commit))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://raw.githubusercontent.com/voxpupuli/puppet-mode/"
+ commit "/puppet-mode.el"))
+ (sha256
+ (base32
+ "1indycxawsl0p2aqqg754f6735q3cmah9vd886rpn0ncc3ipi1xm"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/voxpupuli/puppet-mode")
+ (synopsis "Emacs major mode for the Puppet configuration language")
+ (description
+ "This package provides support for the Puppet configuration language,
+including syntax highlighting, indentation of expressions and statements,
+linting of manifests and integration with Puppet Debugger.")
+ ;; Also incorporates work covered by the Apache License, Version 2.0
+ (license license:gpl3+))))
+
(define-public emacs-god-mode
(let ((commit "6cf0807b6555eb6fcf8387a4e3b667071ef38964")
(revision "1"))