aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-07-21 12:35:10 +0100
committerChristopher Baines <mail@cbaines.net>2018-07-28 18:44:18 +0100
commitbec948f6f81eca6e0c7edb30a0e3d64529002084 (patch)
tree1dd7a057197792b721c1efcb74b617ac8e133b3b
parent48d7ac175f69fea587eaa0358eddb5c76205e8ad (diff)
downloadguix-duplicity-fix.tar
guix-duplicity-fix.tar.gz
gnu: Patch duplicity with --ignore-mdc-error.duplicity-fix
Modify the package to patch gnu.py with an unreleased upstream change to fix duplicity working with recent releases of GnuPG. This change make the package build again. * gnu/packages/backup.scm (duplicity)[arguments]: Patch gnu.py within the patch-source phase.
-rw-r--r--gnu/packages/backup.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 9884f58fc3..0733d9c345 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -105,6 +105,15 @@
(substitute* "duplicity/gpginterface.py"
(("self.call = 'gpg'")
(string-append "self.call = '" (assoc-ref inputs "gnupg") "/bin/gpg'")))
+
+ ;; This matches up with an unreleased upstream fix, it should be
+ ;; removed when the package is updated
+ ;; https://bazaar.launchpad.net/~duplicity-team/duplicity/0.8-series/revision/1308
+ (substitute* "duplicity/gpg.py"
+ (("--no-secmem-warning'\\)")
+ "--no-secmem-warning')
+ gnupg.options.extra_args.append('--ignore-mdc-error')"))
+
(substitute* '("testing/functional/__init__.py"
"testing/overrides/bin/lftp")
(("/bin/sh") (which "sh")))