aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2021-02-23 20:02:14 +0000
committerChristopher Baines <mail@cbaines.net>2021-02-24 08:36:47 +0000
commit3fe3fcf3c56e86a9e59c49eba212d0634d3d68d1 (patch)
tree6253e543b7ef43a3e310114f9ab2ef3d8b1e6b18
parent15c4b98daa4a4cb020f38531eb6be1557f7ee398 (diff)
downloadguix-cross-build-guile-lib-properly.tar
guix-cross-build-guile-lib-properly.tar.gz
gnu: guile-lib: Fix cross compilation.cross-build-guile-lib-properly
These changes were sent upstream as https://lists.gnu.org/archive/html/guile-devel/2021-02/msg00004.html Without this change, the .go files are built for the host architecture, rather than the target. I noticed this when cross building the guix-build-coordinator (for which guile-lib is an input) to the Hurd. * gnu/packages/guile-xyz.scm (guile-lib)[arguments]: Add 'patch-for-cross-compilation phase. [native-inputs]: Add autoconf, automake and gettext. (guile2.0-lib): Adjust to use alist-replace. (guile2.2-lib): Adjust to use alist-replace.
-rw-r--r--gnu/packages/guile-xyz.scm37
1 files changed, 32 insertions, 5 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index ce5aad8ec7..07f81bcc1b 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -116,6 +116,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system guile)
#:use-module (guix utils)
+ #:use-module ((guix build utils) #:select (alist-replace))
#:use-module (ice-9 match)
#:use-module ((srfi srfi-1) #:select (alist-delete)))
@@ -2194,6 +2195,21 @@ library.")
'("GUILE_AUTO_COMPILE=0") ; to prevent guild errors
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-for-cross-compilation
+ (lambda _
+ (substitute* "configure.ac"
+ (("GUILE_FLAGS")
+ "GUILE_FLAGS
+if test \"$cross_compiling\" != no; then
+ GUILE_TARGET=\"--target=$host_alias\"
+ AC_SUBST([GUILE_TARGET])
+fi
+"))
+ (substitute* "am/guile.mk"
+ (("guild compile") "guild compile $(GUILE_TARGET)"))
+ (delete-file "configure") ; trigger the bootstrap phase to run
+ ; autoreconf
+ #t))
(add-before 'configure 'patch-module-dir
(lambda _
(substitute* "src/Makefile.in"
@@ -2204,7 +2220,10 @@ library.")
$(libdir)/guile/@GUILE_EFFECTIVE_VERSION@/site-ccache\n"))
#t)))))
(native-inputs
- `(("guile" ,guile-3.0)
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gettext" ,gettext-minimal)
+ ("guile" ,guile-3.0)
("pkg-config" ,pkg-config)))
(inputs
`(("guile" ,guile-3.0)))
@@ -2225,15 +2244,23 @@ for Guile\".")
(package
(inherit guile-lib)
(name "guile2.0-lib")
- (native-inputs `(("pkg-config" ,pkg-config)))
- (inputs `(("guile" ,guile-2.0)))))
+ (native-inputs
+ (alist-replace "guile" (list guile-2.0)
+ (package-native-inputs guile-lib)))
+ (inputs
+ (alist-replace "guile" (list guile-2.0)
+ (package-inputs guile-lib)))))
(define-public guile2.2-lib
(package
(inherit guile-lib)
(name "guile2.2-lib")
- (native-inputs `(("pkg-config" ,pkg-config)))
- (inputs `(("guile" ,guile-2.2)))))
+ (native-inputs
+ (alist-replace "guile" (list guile-2.2)
+ (package-native-inputs guile-lib)))
+ (inputs
+ (alist-replace "guile" (list guile-2.2)
+ (package-inputs guile-lib)))))
(define-public guile3.0-lib
(deprecated-package "guile3.0-lib" guile-lib))