aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-20 08:20:19 +0000
committerChristopher Baines <mail@cbaines.net>2018-10-22 20:40:03 +0100
commit04dcd759cf2f1fcdea5977e6f017ba4091beb319 (patch)
tree4edc57624183ddde2fde0379491ce7c781b8ba43
parent9861bcd182b1ba89a93630a2178b170a088f0a6b (diff)
downloadguix-cloud-foundry.tar
guix-cloud-foundry.tar.gz
gnu: Add cloud-foundry-cli.cloud-foundry
* gnu/packages/cloud-foundry.scm: New file.
-rw-r--r--gnu/packages/cloud-foundry.scm69
1 files changed, 69 insertions, 0 deletions
diff --git a/gnu/packages/cloud-foundry.scm b/gnu/packages/cloud-foundry.scm
new file mode 100644
index 0000000000..accc83dac9
--- /dev/null
+++ b/gnu/packages/cloud-foundry.scm
@@ -0,0 +1,69 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Christopher Baines <mail@cbaines.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages cloud-foundry)
+ #:use-module (guix build-system go)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix git-download)
+ #:use-module (guix licenses))
+
+(define-public cloud-foundry-cli
+ (package
+ (name "cloud-foundry-cli")
+ (version "6.40.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cloudfoundry/cli.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13k16vgb20i2w7xmjaaviyf98069yi98yysda79hk800h0vwk8xp"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "code.cloudfoundry.org/cli"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda _
+ (substitute*
+ "src/code.cloudfoundry.org/cli/cf/terminal/ui_unix.go"
+ (("/bin/stty")
+ (which "stty")))))
+ ;; This should be redundant once the vendor directory is removed from
+ ;; this package
+ (add-before 'reset-gzip-timestamps 'remove-readonly-gzip-files
+ (lambda* (#:key outputs #:allow-other-keys)
+ (for-each delete-file
+ (find-files
+ (assoc-ref outputs "out")
+ ".*\\.gz"))
+ #t))
+ (add-after 'install 'rename-binary
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (rename-file (string-append out "/bin/cli")
+ (string-append out "/bin/cf"))
+ #t))))))
+ (synopsis "Client for the Cloud Foundry application platform")
+ (description
+ "This package contains the official command line client for Cloud Foundry
+application platform.")
+ (home-page "https://github.com/cloudfoundry/cli")
+ (license asl2.0)))