aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-05-06 16:55:19 -0400
committerLeo Famulari <leo@famulari.name>2018-05-12 16:19:57 -0400
commit241caa62ca315177fd1dfc10a64621a9d29d26dd (patch)
tree04d9866e6898b6a2b374a8ef5a5a1687221d790e
parent8e6450f7e22f47941661b750ad9df41a3ef5afd8 (diff)
downloadguix-241caa62ca315177fd1dfc10a64621a9d29d26dd.tar
guix-241caa62ca315177fd1dfc10a64621a9d29d26dd.tar.gz
gnu: MPD: Remove unecessary dependency on libmad.
MPD already depends on FFmpeg, which uses LAME for MP3 decoding. gnu/packages/mpd.scm (mpd)[inputs]: Remove LIBMAD.
-rw-r--r--gnu/packages/mpd.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 1889035492..6f2ff5d784 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -119,9 +119,10 @@ interfacing MPD in the C, C++ & Objective C languages.")
("flac" ,flac)
("glib" ,glib)
("icu4c" ,icu4c)
+ ;; The LAME decoder comes from FFmpeg, but is added here so that
+ ;; configure picks up the LAME encoder.
("lame" ,lame)
("libid3tag" ,libid3tag)
- ("libmad" ,libmad)
("libmpdclient" ,libmpdclient)
("libsamplerate" ,libsamplerate)
("libsndfile" ,libsndfile)