aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-07-07 18:54:29 +0100
committerChristopher Baines <mail@cbaines.net>2019-07-07 18:54:29 +0100
commit57f88a13ba90cf776cd027e636a9f45cbebfa92b (patch)
treec6469cd18ebe20d7ff12dde735d39e0fc475a764
parentbf187d92e39e93e8e08719de8b08c57db530eed9 (diff)
downloadguix-add-s-tui.tar
guix-add-s-tui.tar.gz
gnu: Add s-tui.add-s-tui
* gnu/packages/admin.scm (s-tui): New variable.
-rw-r--r--gnu/packages/admin.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 411be40f5b..98795966f1 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1453,6 +1453,28 @@ tables. This package contains only the user-space tools needed for ACPI table
development, not the kernel implementation of ACPI.")
(license license:gpl2))) ; dual GPLv2/ACPICA Licence
+(define-public s-tui
+ (package
+ (name "s-tui")
+ (version "0.8.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "s-tui" version))
+ (sha256
+ (base32
+ "00lsh2v4i8rwfyjyxx5lijd6rnk9smcfffhzg5sv94ijpcnh216m"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-psutil" ,python-psutil)
+ ("python-urwid" ,python-urwid)))
+ (home-page "https://github.com/amanusk/s-tui")
+ (synopsis "Interactive terminal stress test and monitoring tool")
+ (description
+ "The Stress Terminal UI displays graphs of the CPU frequency,
+utilization, temperature and power.")
+ (license license:gpl2+)))
+
(define-public stress
(package
(name "stress")