aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore19
-rw-r--r--Makefile.am9
-rw-r--r--VERSION1
-rwxr-xr-xbootstrap.sh3
-rw-r--r--configure.ac14
-rw-r--r--guile.am22
-rw-r--r--guix-build-coordinator/agent.scm0
-rw-r--r--pre-inst-env.in13
8 files changed, 81 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..10520ac
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,19 @@
+*.go
+Makefile.in
+Makefile
+aclocal.m4
+autom4te.cache
+config.log
+config.status
+configure
+
+build-aux/install-sh
+build-aux/missing
+
+*.log
+tests/*.log
+tests/*.trs
+
+pre-inst-env
+
+.local.envrc
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..28298f6
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,9 @@
+include guile.am
+
+SOURCES = \
+ guix-build-coordinator/agent.scm
+
+EXTRA_DIST = \
+ README \
+ bootstrap \
+ pre-inst-env.in
diff --git a/VERSION b/VERSION
new file mode 100644
index 0000000..ba66466
--- /dev/null
+++ b/VERSION
@@ -0,0 +1 @@
+0.0
diff --git a/bootstrap.sh b/bootstrap.sh
new file mode 100755
index 0000000..5af6611
--- /dev/null
+++ b/bootstrap.sh
@@ -0,0 +1,3 @@
+#! /bin/sh
+
+autoreconf --verbose --install --force
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..e60e922
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,14 @@
+AC_INIT([guix-data-service], [m4_translit(m4_esyscmd([cat VERSION]),m4_newline)])
+AC_CONFIG_AUX_DIR([build-aux])
+AM_INIT_AUTOMAKE([gnu color-tests -Wall -Wno-portability foreign])
+
+GUILE_PKG([3.0])
+GUILE_PROGS
+if test "x$GUILD" = "x"; then
+ AC_MSG_ERROR(['guild' binary not found; please check your guile-3.x installation.])
+fi
+
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([pre-inst-env], [chmod +x pre-inst-env])
+
+AC_OUTPUT
diff --git a/guile.am b/guile.am
new file mode 100644
index 0000000..df3df98
--- /dev/null
+++ b/guile.am
@@ -0,0 +1,22 @@
+moddir=$(datadir)/guile/site/$(GUILE_EFFECTIVE_VERSION)
+godir=$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/site-ccache
+
+GOBJECTS = $(SOURCES:%.scm=%.go)
+
+nobase_mod_DATA = $(SOURCES) $(NOCOMP_SOURCES)
+nobase_go_DATA = $(GOBJECTS)
+
+# Make sure source files are installed first, so that the mtime of
+# installed compiled files is greater than that of installed source
+# files. See
+# <http://lists.gnu.org/archive/html/guile-devel/2010-07/msg00125.html>
+# for details.
+guile_install_go_files = install-nobase_goDATA
+$(guile_install_go_files): install-nobase_modDATA
+
+CLEANFILES = $(GOBJECTS)
+EXTRA_DIST = $(SOURCES) $(NOCOMP_SOURCES)
+GUILE_WARNINGS = -Wunbound-variable -Warity-mismatch -Wformat
+SUFFIXES = .scm .go
+.scm.go:
+ $(AM_V_GEN)$(top_builddir)/pre-inst-env $(GUILE_TOOLS) compile $(GUILE_WARNINGS) -o "$@" "$<"
diff --git a/guix-build-coordinator/agent.scm b/guix-build-coordinator/agent.scm
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/guix-build-coordinator/agent.scm
diff --git a/pre-inst-env.in b/pre-inst-env.in
new file mode 100644
index 0000000..ebf1a05
--- /dev/null
+++ b/pre-inst-env.in
@@ -0,0 +1,13 @@
+#!/bin/sh
+
+abs_top_srcdir="`cd "@abs_top_srcdir@" > /dev/null; pwd`"
+abs_top_builddir="`cd "@abs_top_builddir@" > /dev/null; pwd`"
+
+GUILE_LOAD_COMPILED_PATH="$abs_top_builddir${GUILE_LOAD_COMPILED_PATH:+:}$GUILE_LOAD_COMPILED_PATH"
+GUILE_LOAD_PATH="$abs_top_builddir:$abs_top_srcdir${GUILE_LOAD_PATH:+:}:$GUILE_LOAD_PATH"
+export GUILE_LOAD_COMPILED_PATH GUILE_LOAD_PATH
+
+PATH="$abs_top_builddir:$PATH"
+export PATH
+
+exec "$@"