aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-09-27 20:46:53 +0100
committerChristopher Baines <mail@cbaines.net>2020-09-27 20:46:53 +0100
commit46465ab437ab2a15e9d2a4f1ed9e8eca72eee9cb (patch)
tree05de3a8be77510315e7c7089d45e052bfd7af1b4 /configure.ac
parentebfb487d9230be509bad31cb41d84dc8200565bc (diff)
downloadbuild-coordinator-46465ab437ab2a15e9d2a4f1ed9e8eca72eee9cb.tar
build-coordinator-46465ab437ab2a15e9d2a4f1ed9e8eca72eee9cb.tar.gz
Tweak some things to maybe enable cross compilation
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2a33f4d..9995c38 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,6 +8,11 @@ if test "x$GUILD" = "x"; then
AC_MSG_ERROR(['guild' binary not found; please check your guile-3.x installation.])
fi
+if test "$cross_compiling" != no; then
+ GUILE_TARGET="--target=$host_alias"
+ AC_SUBST([GUILE_TARGET])
+fi
+
AC_PATH_PROG([guix], [guix])
AC_PATH_PROG([sqitch], [sqitch])