summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-01-03 22:03:34 +0000
committerChristopher Baines <christopher.baines@digital.cabinet-office.gov.uk>2019-04-09 00:49:25 +0100
commitf4a99d175b292cc149505f52df5bfa0204a5047d (patch)
treeb2b6bc05a50be1776526986b307d3549c6a732b0
parent55944ff4b15410eaf17d06bbf8b7bc7cd393382c (diff)
downloadgnu-guix-release_32.tar
gnu-guix-release_32.tar.gz
gnu: postgresql: Build with openssl support.release_32
* gnu/packages/databases.scm (postgresql)[arguments]: Add --with-openssl to [inputs]: Add openssl.
-rw-r--r--gnu/packages/databases.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 6b0ff5d07c..7d5502e560 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -751,7 +751,7 @@ as a drop-in replacement of MySQL.")
(patches (search-patches "postgresql-disable-resolve_symlinks.patch"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '("--with-uuid=e2fs")
+ `(#:configure-flags '("--with-uuid=e2fs" "--with-openssl")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-/bin/sh
@@ -770,6 +770,7 @@ as a drop-in replacement of MySQL.")
(inputs
`(("readline" ,readline)
("libuuid" ,util-linux)
+ ("openssl" ,openssl)
("zlib" ,zlib)))
(home-page "https://www.postgresql.org/")
(synopsis "Powerful object-relational database system")