aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJeremy T. Bouse <jbouse@debian.org>2009-11-27 16:20:12 -0500
committerJeremy T. Bouse <jbouse@debian.org>2009-11-27 16:20:12 -0500
commited280d5ac360e2af796e9bd973d7b4df89f0c449 (patch)
treece892d6ce9dad8c0ecbc9cbe73f8095195bef0b4 /setup.py
parent176c6caf4ea7918e1698438634b237fab8456471 (diff)
downloadpython-paramiko-ed280d5ac360e2af796e9bd973d7b4df89f0c449.tar
python-paramiko-ed280d5ac360e2af796e9bd973d7b4df89f0c449.tar.gz
Imported Upstream version 1.7.4upstream/1.7.4
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py31
1 files changed, 25 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index ce7d047..2041fea 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,4 @@
-from distutils.core import setup
-
-# Copyright (C) 2003-2005 Robey Pointer <robey@lag.net>
+# Copyright (C) 2003-2008 Robey Pointer <robey@lag.net>
#
# This file is part of paramiko.
#
@@ -26,17 +24,37 @@ connections between python scripts. All major ciphers and hash methods
are supported. SFTP client and server mode are both supported too.
Required packages:
- pyCrypt
+ pyCrypto
'''
+# if someday we want to *require* setuptools, uncomment this:
+# (it will cause setuptools to be automatically downloaded)
+#import ez_setup
+#ez_setup.use_setuptools()
+
+import sys
+try:
+ from setuptools import setup
+ kw = {
+ 'install_requires': 'pycrypto >= 1.9',
+ }
+except ImportError:
+ from distutils.core import setup
+ kw = {}
+
+if sys.platform == 'darwin':
+ import setup_helper
+ setup_helper.install_custom_make_tarball()
+
+
setup(name = "paramiko",
- version = "1.5.2",
+ version = "1.7.4",
description = "SSH2 protocol library",
author = "Robey Pointer",
author_email = "robey@lag.net",
url = "http://www.lag.net/paramiko/",
packages = [ 'paramiko' ],
- download_url = 'http://www.lag.net/paramiko/download/paramiko-1.5.2.zip',
+ download_url = 'http://www.lag.net/paramiko/download/paramiko-1.7.4.zip',
license = 'LGPL',
platforms = 'Posix; MacOS X; Windows',
classifiers = [ 'Development Status :: 5 - Production/Stable',
@@ -46,4 +64,5 @@ setup(name = "paramiko",
'Topic :: Internet',
'Topic :: Security :: Cryptography' ],
long_description = longdesc,
+ **kw
)