aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJeremy T. Bouse <jbouse@debian.org>2009-11-27 16:20:09 -0500
committerJeremy T. Bouse <jbouse@debian.org>2009-11-27 16:20:09 -0500
commit176c6caf4ea7918e1698438634b237fab8456471 (patch)
tree6e2a8e5be1af2a6ec324fdbf99589aa099f1ec2a /setup.py
downloadpython-paramiko-176c6caf4ea7918e1698438634b237fab8456471.tar
python-paramiko-176c6caf4ea7918e1698438634b237fab8456471.tar.gz
Imported Upstream version 1.5.2upstream/1.5.2
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py49
1 files changed, 49 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..ce7d047
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,49 @@
+from distutils.core import setup
+
+# Copyright (C) 2003-2005 Robey Pointer <robey@lag.net>
+#
+# This file is part of paramiko.
+#
+# Paramiko is free software; you can redistribute it and/or modify it under the
+# terms of the GNU Lesser General Public License as published by the Free
+# Software Foundation; either version 2.1 of the License, or (at your option)
+# any later version.
+#
+# Paramiko is distrubuted in the hope that it will be useful, but WITHOUT ANY
+# WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR
+# A PARTICULAR PURPOSE. See the GNU Lesser General Public License for more
+# details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with Paramiko; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+
+
+longdesc = '''
+This is a library for making SSH2 connections (client or server).
+Emphasis is on using SSH2 as an alternative to SSL for making secure
+connections between python scripts. All major ciphers and hash methods
+are supported. SFTP client and server mode are both supported too.
+
+Required packages:
+ pyCrypt
+'''
+
+setup(name = "paramiko",
+ version = "1.5.2",
+ description = "SSH2 protocol library",
+ author = "Robey Pointer",
+ author_email = "robey@lag.net",
+ url = "http://www.lag.net/paramiko/",
+ packages = [ 'paramiko' ],
+ download_url = 'http://www.lag.net/paramiko/download/paramiko-1.5.2.zip',
+ license = 'LGPL',
+ platforms = 'Posix; MacOS X; Windows',
+ classifiers = [ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: GNU Library or Lesser General Public License (LGPL)',
+ 'Operating System :: OS Independent',
+ 'Topic :: Internet',
+ 'Topic :: Security :: Cryptography' ],
+ long_description = longdesc,
+ )