aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/javascript.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2024-04-20 11:47:50 +0100
committerChristopher Baines <mail@cbaines.net>2024-04-20 11:47:50 +0100
commitda77ea23daa0bfa4a73290dff99b22d6825ff80b (patch)
tree748d24e62b93c8ab8f999d6415d9f65c3d317da2 /gnu/packages/javascript.scm
parent4eeb6922449285f9bce615f6e4ffe4375fa0233f (diff)
parent949f97f7f98ac74306b9de79c93790337d804e32 (diff)
downloadguix-chris-core-updates-no-duplicates-attempt.tar
guix-chris-core-updates-no-duplicates-attempt.tar.gz
Merge commit '949f97f7f9' into core-update-new-2chris-core-updates-no-duplicates-attempt
Change-Id: Ibbd851541da42cc052ba58195fee033daadd57e5 Conflicts: gnu/local.mk gnu/packages/bioinformatics.scm gnu/packages/dictionaries.scm gnu/packages/display-managers.scm gnu/packages/engineering.scm gnu/packages/geo.scm gnu/packages/gl.scm gnu/packages/glib.scm gnu/packages/gnome-xyz.scm gnu/packages/gnome.scm gnu/packages/gtk.scm gnu/packages/image-processing.scm gnu/packages/linux.scm gnu/packages/llvm.scm gnu/packages/mail.scm gnu/packages/patches/eudev-rules-directory.patch gnu/packages/plotutils.scm gnu/packages/sdl.scm gnu/packages/syndication.scm
Diffstat (limited to 'gnu/packages/javascript.scm')
-rw-r--r--gnu/packages/javascript.scm32
1 files changed, 21 insertions, 11 deletions
diff --git a/gnu/packages/javascript.scm b/gnu/packages/javascript.scm
index c6e7443f85..fba96b06a8 100644
--- a/gnu/packages/javascript.scm
+++ b/gnu/packages/javascript.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017, 2019, 2020, 2022, 2023 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017, 2018, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2017-2020, 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017-2020, 2022-2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2021 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
@@ -826,20 +826,29 @@ roots, or wrestle with obscure build systems.")
(define-public quickjs
(package
(name "quickjs")
- (version "2021-03-27")
+ (version "2024-01-13")
(source (origin
(method url-fetch)
(uri (string-append "https://bellard.org/quickjs/quickjs-"
version ".tar.xz"))
(sha256
(base32
- "06pywwpmfwjz225h59wf90q96a2fd66qfcw5xa6m6y9k9k7glnx4"))))
+ "00rf45l1bx0yhlv11gn3bbyfqw9724c153bc93mlp9dzjpwghjrw"))
+ (snippet
+ #~(begin (use-modules (guix build utils))
+ (for-each delete-file
+ '("doc/quickjs.pdf"
+ "doc/quickjs.html"
+ "doc/jsbignum.pdf"
+ "doc/jsbignum.html"))))))
(build-system gnu-build-system)
(arguments
(list #:make-flags
- #~(list "prefix="
- (string-append "DESTDIR=" #$output)
- #$@(if (target-riscv64?) '("LDFLAGS=-latomic") '()))
+ #~(list (string-append "PREFIX=" #$output)
+ #$@(if (or (target-riscv64?)
+ (target-ppc32?))
+ '("LDFLAGS=-latomic")
+ '()))
#:phases #~(modify-phases %standard-phases
(delete 'configure)
(replace 'check
@@ -848,11 +857,12 @@ roots, or wrestle with obscure build systems.")
(invoke "make" "microbench")))))))
(home-page "https://bellard.org/quickjs/")
(synopsis "Small embeddable Javascript engine")
- (description "QuickJS supports the ES2020 specification including modules,
-asynchronous generators, proxies, BigInt and BigDecimal. It can compile
-Javascript sources to executables with no external dependency. It includes a
-command line interpreter with contextual colorization implemented in
-Javascript and a small built-in standard library with C library wrappers.")
+ (description "QuickJS supports the ES2023 specification including modules,
+asynchronous generators, proxies, BigInt, BigDecimal, BigFloat and operator
+overloading. It can compile Javascript sources to executables with no external
+dependency. It includes a command line interpreter with contextual colorization
+implemented in Javascript and a small built-in standard library with C library
+wrappers.")
(license license:expat)))
(define-public duktape