aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2022-01-02 16:31:46 +0000
committerChristopher Baines <mail@cbaines.net>2022-01-02 16:31:46 +0000
commitea78649726cccc352b0170161effdac390a725c4 (patch)
treec4bbba59fe6c613c917037303743e1e1af440de1 /configure.ac
parent9a7dac283466b5c39533adb950cf78d057f2c08d (diff)
downloadbuild-coordinator-ea78649726cccc352b0170161effdac390a725c4.tar
build-coordinator-ea78649726cccc352b0170161effdac390a725c4.tar.gz
Don't create the guix-build-coordinator script for a minimal build
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 10 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 1e6a6b0..0eeae84 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,23 +44,25 @@ if test "x$have_guile_fibers" != "xyes"; then
CONFSOURCES="MINIMALSOURCES"
else
CONFSOURCES="ALLSOURCES"
+
+ AC_CONFIG_FILES(
+ [scripts/guix-build-coordinator],
+ [chmod +x scripts/guix-build-coordinator]
+ )
+ AC_CONFIG_FILES(
+ [scripts/guix-build-coordinator-queue-builds-from-guix-data-service],
+ [chmod +x scripts/guix-build-coordinator-queue-builds-from-guix-data-service]
+ )
fi
AC_SUBST([CONFSOURCES])
AC_CONFIG_FILES([Makefile])
AC_CONFIG_FILES([pre-inst-env], [chmod +x pre-inst-env])
AC_CONFIG_FILES([guix-build-coordinator/config.scm])
-AC_CONFIG_FILES(
- [scripts/guix-build-coordinator],
- [chmod +x scripts/guix-build-coordinator]
-)
+
AC_CONFIG_FILES(
[scripts/guix-build-coordinator-agent],
[chmod +x scripts/guix-build-coordinator-agent]
)
-AC_CONFIG_FILES(
- [scripts/guix-build-coordinator-queue-builds-from-guix-data-service],
- [chmod +x scripts/guix-build-coordinator-queue-builds-from-guix-data-service]
-)
AC_OUTPUT