aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2022-01-02 16:19:10 +0000
committerChristopher Baines <mail@cbaines.net>2022-01-02 16:19:10 +0000
commit9a7dac283466b5c39533adb950cf78d057f2c08d (patch)
treebff4f33c9b835b8dd138d78d129aebc94b38c174 /configure.ac
parent2ff82fcef4c07b7b847c678ac9ff296a66b7d29f (diff)
downloadbuild-coordinator-9a7dac283466b5c39533adb950cf78d057f2c08d.tar
build-coordinator-9a7dac283466b5c39533adb950cf78d057f2c08d.tar.gz
Hack the autotools stuff to try and allow minimal builds
No idea what this stuff is, but modify it with the intent of allowing building just the sources related to the agent, if guile-fibers is missing. This should make it easier to avoid problems in Guix where things like guile-fibers are currently broken for aarch64-linux, and also avoid having a load of perl dependencies for the agent, which doesn't use sqitch.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 013cbfe..1e6a6b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -38,6 +38,15 @@ if test "x$have_guile_lib" != "xyes"; then
AC_MSG_ERROR([Guile-lib is missing; please install it.])
fi
+dnl Check for guile-fibers.
+GUILE_MODULE_AVAILABLE([have_guile_fibers], [(fibers)])
+if test "x$have_guile_fibers" != "xyes"; then
+ CONFSOURCES="MINIMALSOURCES"
+else
+ CONFSOURCES="ALLSOURCES"
+fi
+AC_SUBST([CONFSOURCES])
+
AC_CONFIG_FILES([Makefile])
AC_CONFIG_FILES([pre-inst-env], [chmod +x pre-inst-env])
AC_CONFIG_FILES([guix-build-coordinator/config.scm])