aboutsummaryrefslogtreecommitdiff
path: root/src/or/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/or/Makefile.am')
-rw-r--r--src/or/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/src/or/Makefile.am b/src/or/Makefile.am
index fd86aa21e..dd6c85b89 100644
--- a/src/or/Makefile.am
+++ b/src/or/Makefile.am
@@ -4,11 +4,19 @@ noinst_PROGRAMS = test
bin_PROGRAMS = tor
+if BUILD_NT_SERVICES
+PLATFORM_SOURCES=ntmain.c
+else
+PLATFORM_SOURCES=
+endif
+
+EXTRA_DIST=ntmain.c
+
tor_SOURCES = buffers.c circuitbuild.c circuitlist.c \
circuituse.c command.c config.c \
connection.c connection_edge.c connection_or.c control.c \
cpuworker.c directory.c dirserv.c dirvote.c \
- dns.c dnsserv.c hibernate.c main.c \
+ dns.c dnsserv.c hibernate.c main.c $(PLATFORM_SOURCES) \
onion.c policies.c relay.c rendcommon.c rendclient.c rendmid.c \
rendservice.c rephist.c router.c routerlist.c routerparse.c \
eventdns.c \
@@ -25,7 +33,7 @@ test_SOURCES = buffers.c circuitbuild.c circuitlist.c \
circuituse.c command.c config.c \
connection.c connection_edge.c connection_or.c control.c \
cpuworker.c directory.c dirserv.c dirvote.c \
- dns.c dnsserv.c hibernate.c main.c \
+ dns.c dnsserv.c hibernate.c main.c $(PLATFORM_SOURCES) \
onion.c policies.c relay.c rendcommon.c rendclient.c rendmid.c \
rendservice.c rephist.c router.c routerlist.c routerparse.c \
eventdns.c \