aboutsummaryrefslogtreecommitdiff
path: root/src/or/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/or/Makefile.am')
-rw-r--r--src/or/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/or/Makefile.am b/src/or/Makefile.am
index e9916d518..04a66d061 100644
--- a/src/or/Makefile.am
+++ b/src/or/Makefile.am
@@ -42,7 +42,7 @@ tor_LDFLAGS = @TOR_LDFLAGS_zlib@ @TOR_LDFLAGS_openssl@ @TOR_LDFLAGS_libevent@
tor_LDADD = ../common/libor.a ../common/libor-crypto.a \
../common/libor-event.a \
-lz -lm -levent -lssl -lcrypto @TOR_LIB_WS32@ @TOR_LIB_GDI@
-test_SOURCES = $(COMMON_SRC) test_data.c test.c
+test_SOURCES = $(COMMON_SRC) test_data.c test.c tinytest.c
test_LDFLAGS = @TOR_LDFLAGS_zlib@ @TOR_LDFLAGS_openssl@ \
@TOR_LDFLAGS_libevent@
@@ -50,7 +50,10 @@ test_LDADD = ../common/libor.a ../common/libor-crypto.a \
../common/libor-event.a \
-lz -lm -levent -lssl -lcrypto @TOR_LIB_WS32@ @TOR_LIB_GDI@
-noinst_HEADERS = or.h eventdns.h eventdns_tor.h micro-revision.i
+noinst_HEADERS = or.h eventdns.h eventdns_tor.h micro-revision.i tinytest.h \
+ tinytest_macros.h
+
+EXTRA_DIST = tinytest_demo.c
config_codedigest.o: or_sha1.i