aboutsummaryrefslogtreecommitdiff
path: root/src/or/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/or/Makefile.am')
-rw-r--r--src/or/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/or/Makefile.am b/src/or/Makefile.am
index 104854078..1d17bd476 100644
--- a/src/or/Makefile.am
+++ b/src/or/Makefile.am
@@ -41,11 +41,15 @@ noinst_HEADERS = or.h eventdns.h eventdns_tor.h micro-revision.i
tor_main.o: micro-revision.i
micro-revision.i: FORCE
- @if test -d ../../.svn && test -x "`which svn 2>&1;true`" ; then \
+ @svkdir=$$SVKROOT; \
+ if test "x$$svkdir" = x ; then \
+ svkdir=$$HOME/.svk; \
+ fi; \
+ if test -d ../../.svn && test -x "`which svn 2>&1;true`" ; then \
svn info ../.. | \
sed -n 's/^Revision: \([0-9][0-9]*\).*/"\1"/p' > micro-revision.tmp \
|| true; \
- elif test -x "`which svk 2>&1;true`" && test -d ~/.svk/local; then \
+ elif test -x "`which svk 2>&1;true`" && test -d $$svkdir/local; then \
location=../..; \
rev=x; \
while test x$$rev = xx; do \