aboutsummaryrefslogtreecommitdiff
path: root/src/or/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2007-06-07 16:14:55 +0000
committerNick Mathewson <nickm@torproject.org>2007-06-07 16:14:55 +0000
commit529cbe34b0253483dbc1a8bbd597b30ad28ca53a (patch)
tree19a1e99819f2b750efbd6d0bb1e4b49ab8b68470 /src/or/Makefile.am
parent8db1b61a267d9d55796f41e6114eb6fe27b05e24 (diff)
downloadtor-529cbe34b0253483dbc1a8bbd597b30ad28ca53a.tar
tor-529cbe34b0253483dbc1a8bbd597b30ad28ca53a.tar.gz
r13292@catbus: nickm | 2007-06-06 17:34:15 -0400
Check for non-standard SVK directories properly. Inspired by debian bug #420899 and related discussion on SVK list. svn:r10522
Diffstat (limited to 'src/or/Makefile.am')
-rw-r--r--src/or/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/or/Makefile.am b/src/or/Makefile.am
index 104854078..1d17bd476 100644
--- a/src/or/Makefile.am
+++ b/src/or/Makefile.am
@@ -41,11 +41,15 @@ noinst_HEADERS = or.h eventdns.h eventdns_tor.h micro-revision.i
tor_main.o: micro-revision.i
micro-revision.i: FORCE
- @if test -d ../../.svn && test -x "`which svn 2>&1;true`" ; then \
+ @svkdir=$$SVKROOT; \
+ if test "x$$svkdir" = x ; then \
+ svkdir=$$HOME/.svk; \
+ fi; \
+ if test -d ../../.svn && test -x "`which svn 2>&1;true`" ; then \
svn info ../.. | \
sed -n 's/^Revision: \([0-9][0-9]*\).*/"\1"/p' > micro-revision.tmp \
|| true; \
- elif test -x "`which svk 2>&1;true`" && test -d ~/.svk/local; then \
+ elif test -x "`which svk 2>&1;true`" && test -d $$svkdir/local; then \
location=../..; \
rev=x; \
while test x$$rev = xx; do \