aboutsummaryrefslogtreecommitdiff
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
new file mode 100644
index 000000000..f7fa778f1
--- /dev/null
+++ b/src/common/Makefile.am
@@ -0,0 +1,14 @@
+
+noinst_LIBRARIES = libor.a
+
+#CFLAGS = -Wall -Wpointer-arith -O2
+
+libor_a_SOURCES = cell.c config.c key.c log.c onion.c opcell.c \
+ routent.c scheduler.c utils.c
+
+# ss.h is not used anywhere, distributing it just because
+
+noinst_HEADERS = cell.h config.h key.h log.h onion.h opcell.h \
+ policies.h routent.h scheduler.h utils.h \
+ ss.h version.h
+