aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 9 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index d164d4c75..dc12c1694 100755
--- a/debian/rules
+++ b/debian/rules
@@ -66,6 +66,11 @@ endif
configure: patch-stamp
config.status: configure
+ # clean up test.h stuff. XXX - expected to no longer be needed after tor-0.2.2.4-alpha
+ rm -f src/test/test.h.orig
+ ! [ -e src/test/test.h ] || mv src/test/test.h src/test/test.h.orig
+ cp debian/src-test-test.h src/test/test.h
+
@if [ "$(LOCALHOST_IP)" != "127.0.0.1" ]; then echo; echo; echo; echo; echo; echo "######################################################################"; echo "WARNING: This system does not think localhost is 127.0.0.1. Will ignore result of testsuite. Please fix your system/chroot."; echo "######################################################################"; echo; echo; echo; echo; echo "Note: 'getent hosts localhost' should return '127.0.0.1 localhost'"; echo; fi
dh_testdir
CFLAGS="$(CFLAGS)" ./configure \
@@ -135,6 +140,10 @@ clean: unpatch
[ ! -f Makefile ] || $(MAKE) distclean
+ # clean up test.h stuff. XXX - expected to no longer be needed after tor-0.2.2.4-alpha
+ rm -f src/test/test.h
+ ! [ -e src/test/test.h.orig ] || mv src/test/test.h.orig src/test/test.h
+
# Normally the .deb wouldn't ship with a ../.git
if [ -d .git ] && which git >/dev/null; then \
echo "\"`git rev-parse --short=16 HEAD`\"" > "debian/micro-revision.i" ; \