aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index dbeb756ce..08adf087d 100644
--- a/configure.in
+++ b/configure.in
@@ -619,6 +619,12 @@ AC_SUBST(LOCALSTATEDIR)
AH_TEMPLATE([LOCALSTATEDIR], [Default location to store state files.])
AC_DEFINE_UNQUOTED(LOCALSTATEDIR,"$LOCALSTATEDIR")
+dnl Note: this is not the same as Tor's "DataDir" config option.
+DATADIR=`eval echo $datadir`
+AC_SUBST(DATADIR)
+AH_TEMPLATE([DATADIR], [Default location for platform-independent read-only data.])
+AC_DEFINE_UNQUOTED(DATADIR,"$DATADIR")
+
# Set CFLAGS _after_ all the above checks, since our warnings are stricter
# than autoconf's macros like.
if test $ac_cv_c_compiler_gnu = yes; then