aboutsummaryrefslogtreecommitdiff
path: root/src/tools/Makefile.am
diff options
context:
space:
mode:
authorSebastian Hahn <sebastian@torproject.org>2010-04-14 16:48:05 +0200
committerSebastian Hahn <sebastian@torproject.org>2010-04-14 19:28:21 +0200
commit71fb687ddd2d9c11dbacbc9e115b1c95620ae5bd (patch)
tree91c03a0ed432f8cf409f893ae0a810d416161242 /src/tools/Makefile.am
parentfe57aab2832160d1c256aa9d6e70cd5e1cd29aa4 (diff)
downloadtor-71fb687ddd2d9c11dbacbc9e115b1c95620ae5bd.tar
tor-71fb687ddd2d9c11dbacbc9e115b1c95620ae5bd.tar.gz
Add --enable-static-zlib option
Works like the --enable-static-openssl/libevent options. Requires --with-zlib-dir to be set. Note that other dependencies might still pull in a dynamicly linked zlib, if you don't link them in statically too.
Diffstat (limited to 'src/tools/Makefile.am')
-rw-r--r--src/tools/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/tools/Makefile.am b/src/tools/Makefile.am
index be03f8d89..1bb507684 100644
--- a/src/tools/Makefile.am
+++ b/src/tools/Makefile.am
@@ -9,10 +9,10 @@ tor_gencert_SOURCES = tor-gencert.c
tor_gencert_LDFLAGS = @TOR_LDFLAGS_zlib@ @TOR_LDFLAGS_openssl@ \
@TOR_LDFLAGS_libevent@
tor_gencert_LDADD = ../common/libor.a ../common/libor-crypto.a \
- -lm -lz @TOR_LIBEVENT_LIBS@ @TOR_OPENSSL_LIBS@ @TOR_LIB_WS32@ @TOR_LIB_GDI@
+ -lm @TOR_ZLIB_LIBS@ @TOR_LIBEVENT_LIBS@ @TOR_OPENSSL_LIBS@ @TOR_LIB_WS32@ @TOR_LIB_GDI@
tor_checkkey_SOURCES = tor-checkkey.c
tor_checkkey_LDFLAGS = @TOR_LDFLAGS_zlib@ @TOR_LDFLAGS_openssl@ \
@TOR_LDFLAGS_libevent@
tor_checkkey_LDADD = ../common/libor.a ../common/libor-crypto.a \
- -lm -lz @TOR_LIBEVENT_LIBS@ @TOR_OPENSSL_LIBS@ @TOR_LIB_WS32@ @TOR_LIB_GDI@
+ -lm @TOR_ZLIB_LIBS@ @TOR_LIBEVENT_LIBS@ @TOR_OPENSSL_LIBS@ @TOR_LIB_WS32@ @TOR_LIB_GDI@