aboutsummaryrefslogtreecommitdiff
path: root/src/test/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2010-03-08 23:24:24 -0500
committerNick Mathewson <nickm@torproject.org>2010-09-27 14:22:18 -0400
commitbeb52352f2aeefb69ae2ee67e4e456346e28e40e (patch)
tree972604d7968871f45407fac96234d9490b100c7e /src/test/Makefile.am
parentffd5070b04b3db4409d8e3dc933ffc7d12b5219d (diff)
downloadtor-beb52352f2aeefb69ae2ee67e4e456346e28e40e.tar
tor-beb52352f2aeefb69ae2ee67e4e456346e28e40e.tar.gz
Fix build with automake 1.6
automake 1.6 doesn't like using a conditional += to add stuff to foo_LDADD. Instead you need to conditionally define a variable, then non-conditionally put that variable in foo_LDADD.
Diffstat (limited to 'src/test/Makefile.am')
-rw-r--r--src/test/Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/src/test/Makefile.am b/src/test/Makefile.am
index d6f217658..cfe330c74 100644
--- a/src/test/Makefile.am
+++ b/src/test/Makefile.am
@@ -21,15 +21,18 @@ test_SOURCES = \
test_util.c \
tinytest.c
+if USE_BUFFEREVENTS
+levent_openssl_lib = -levent_openssl
+else
+levent_openssl_lib =
+endif
+
test_LDFLAGS = @TOR_LDFLAGS_zlib@ @TOR_LDFLAGS_openssl@ \
@TOR_LDFLAGS_libevent@
test_LDADD = ../or/libtor.a ../common/libor.a ../common/libor-crypto.a \
../common/libor-event.a \
- @TOR_ZLIB_LIBS@ -lm @TOR_LIBEVENT_LIBS@ @TOR_OPENSSL_LIBS@ @TOR_LIB_WS32@ @TOR_LIB_GDI@
-
-if USE_BUFFEREVENTS
-test_LDADD += -levent_openssl
-endif
+ @TOR_ZLIB_LIBS@ -lm @TOR_LIBEVENT_LIBS@ @TOR_OPENSSL_LIBS@ \
+ @TOR_LIB_WS32@ @TOR_LIB_GDI@ $(levent_openssl_lib)
noinst_HEADERS = tinytest.h tinytest_macros.h test.h