aboutsummaryrefslogtreecommitdiff
path: root/src/test/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2009-08-14 14:34:16 -0400
committerNick Mathewson <nickm@torproject.org>2010-09-27 12:31:14 -0400
commitbd3612cd2b4c49fd9f9aec68b6268973e43f2b63 (patch)
treeec5e092ec63d687a326618e805066731abac637b /src/test/Makefile.am
parentfc4ddafab81d5ca229436eeb0c460634e03cb2ca (diff)
downloadtor-bd3612cd2b4c49fd9f9aec68b6268973e43f2b63.tar
tor-bd3612cd2b4c49fd9f9aec68b6268973e43f2b63.tar.gz
Get SSL connections and linked connections working with bufferevents.
Clients are now verified to work and build circuits correctly. There are still a few warnings given here and there that I need to look into.
Diffstat (limited to 'src/test/Makefile.am')
-rw-r--r--src/test/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/test/Makefile.am b/src/test/Makefile.am
index 546fa2f4b..d6f217658 100644
--- a/src/test/Makefile.am
+++ b/src/test/Makefile.am
@@ -27,4 +27,10 @@ test_LDADD = ../or/libtor.a ../common/libor.a ../common/libor-crypto.a \
../common/libor-event.a \
@TOR_ZLIB_LIBS@ -lm @TOR_LIBEVENT_LIBS@ @TOR_OPENSSL_LIBS@ @TOR_LIB_WS32@ @TOR_LIB_GDI@
+if USE_BUFFEREVENTS
+test_LDADD += -levent_openssl
+endif
+
noinst_HEADERS = tinytest.h tinytest_macros.h test.h
+
+