aboutsummaryrefslogtreecommitdiff
path: root/src/or/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2007-04-11 16:28:44 +0000
committerNick Mathewson <nickm@torproject.org>2007-04-11 16:28:44 +0000
commit795aa1a196630f8b574d69e07ffb353ebeb40ad9 (patch)
tree7885b5053dfd1ffb709f1d90c6e097b7ae078b51 /src/or/Makefile.am
parent38a5f0950250ad21e48ad60c1036621c58ecd9d4 (diff)
downloadtor-795aa1a196630f8b574d69e07ffb353ebeb40ad9.tar
tor-795aa1a196630f8b574d69e07ffb353ebeb40ad9.tar.gz
r12351@catbus: nickm | 2007-04-11 12:09:46 -0400
More autoconf hacking: use same machinery to find zlib as for openssl and libevent. Have unified library finder include setup for --with variable. Start trying to suggest to the user what packages they should install if finding the library fails. svn:r9945
Diffstat (limited to 'src/or/Makefile.am')
-rw-r--r--src/or/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/or/Makefile.am b/src/or/Makefile.am
index 74def2558..9991a67a2 100644
--- a/src/or/Makefile.am
+++ b/src/or/Makefile.am
@@ -13,7 +13,7 @@ tor_SOURCES = buffers.c circuitbuild.c circuitlist.c \
eventdns.c \
tor_main.c
-tor_LDADD = ../common/libor.a ../common/libor-crypto.a -lz
+tor_LDADD = ../common/libor.a ../common/libor-crypto.a
test_SOURCES = buffers.c circuitbuild.c circuitlist.c \
circuituse.c command.c config.c \
@@ -24,7 +24,7 @@ test_SOURCES = buffers.c circuitbuild.c circuitlist.c \
eventdns.c \
test.c
-test_LDADD = ../common/libor.a ../common/libor-crypto.a -lz
+test_LDADD = ../common/libor.a ../common/libor-crypto.a
noinst_HEADERS = or.h eventdns.h eventdns_tor.h