aboutsummaryrefslogtreecommitdiff
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2008-07-25 14:43:24 +0000
committerNick Mathewson <nickm@torproject.org>2008-07-25 14:43:24 +0000
commit9da0482007cada9ff7da4ef2035bb0e7ed2d0ee5 (patch)
treeeed9a63280ea5cf4d3613dfb958b1a607715b00d /src/common/Makefile.am
parentefc7f1ef8fdfa00d8574e66aa0f20036b053dc11 (diff)
downloadtor-9da0482007cada9ff7da4ef2035bb0e7ed2d0ee5.tar
tor-9da0482007cada9ff7da4ef2035bb0e7ed2d0ee5.tar.gz
r17358@pc-10-8-1-079: nickm | 2008-07-25 16:41:03 +0200
Split out the address manipulation functions from compat and util: they were about 21% of the total of those, and spread out too much. svn:r16208
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index 174d8ea99..105c41334 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -9,8 +9,8 @@ else
libor_extra_source=
endif
-libor_a_SOURCES = log.c util.c compat.c container.c mempool.c memarea.c \
- $(libor_extra_source)
+libor_a_SOURCES = address.c log.c util.c compat.c container.c mempool.c \
+ memarea.c $(libor_extra_source)
libor_crypto_a_SOURCES = crypto.c aes.c tortls.c torgzip.c
-noinst_HEADERS = log.h crypto.h test.h util.h compat.h aes.h torint.h tortls.h strlcpy.c strlcat.c torgzip.h container.h ht.h mempool.h memarea.h ciphers.inc
+noinst_HEADERS = address.h log.h crypto.h test.h util.h compat.h aes.h torint.h tortls.h strlcpy.c strlcat.c torgzip.h container.h ht.h mempool.h memarea.h ciphers.inc